Windows volume mapping error with access permissions: Change to 0770

I am running Docker Windows and am trying to run Nextcloud in a container, with all the data on a Windows volume (12TB in RAID-5) that I use for all my server’s data. I originally tried mapping all the folders described on the Nextcloud Docker Hub page to the respective folders on my Windows volume.
For example I did: docker run -v D:\nextcloud\www\html\data:/var/www/html/data nextcloud. All the data ended up in the folder visible from Windows, but the server wasn’t accessible, though it was running.
I then tried only mapping the data folder to my Windows volume. This time the server was accessible, but after initialization I got an error, saying I should change the data storage to access permission 0770. I did it like this: chmod 0770 /var/www/html/data. The error persists.

What could be the problem here? Both with the data folder access and the server not working correctly when storing all data on a mapped volume.

Edit: It seems like when setting the data storage to be on a mapped volume, Nextcloud takes around five minutes to initialize. Without mapped volumes this initialization takes around ten seconds. I assumed there was something wrong when it didn’t work after the expected initialization time.

how is the windows-space formatted? ntfs? that is known for not working correctly with linux-permissions.

It is. It works now (I’ve disabled permission checks), but it’s a lot slower than when it writes directly to the VM.

Edit: This is what I’ve done: 'check_data_directory_permissions' => false,