Windows client: "Failed to connect to Nextcloud at https:/nextcloud.example.com: Unknown error"

My installtion of Nextcloud seems to be working great (23.0.2, Docker).
I access my self-hosted containers using Cloudflare Tunnels and Google Oath access to the Tunnel.

When I first try to login to the Windows desktop app, I first get presented with an Untrusted Certificate warning. The certificate name is “sni.cloudflaressl.com” though my Nextcloud instance is running on nextcloud.example.com. I do have the option to “Trust this certificate anyway,” which I check and then am returned to the login screen.

I then get the error in the subject line.

However, if I connect locally to my next cloud instance using the private IP (http://192.168.100.22:8888, no SSL) I can connect fine.

The Android client doesn’t work either, though I don’t get the certificate popup to start with. It just states “Testing Connection” then returns “Malformed server configuration.”

I’m stumped on how to troubleshoot this, though I suspect it might be related to the certificate (which I don’t believe I can change on the Cloudflare side).

Any thoughts on how I can resolve this? I really want to use Nextcloud, but the lack of file synching (b/c I can’t get the Windows client to log in) has me dead in the water.

Thank you.

Since Cloudflare uses SNI for their Tunnels, is it possible that this is the problem?

“The Windows WebDAV Client might not support Server Name Indication (SNI) on encrypted connections. If you encounter an error mounting an SSL-encrypted Nextcloud instance, contact your provider about assigning a dedicated IP address for your SSL-based server.”

Switching to the Cloudflare plan that would enable me to drop SNI is $200/month. :slight_smile: I’ll stick with Office365 $6/month plan. :slight_smile: