Windows client - "Connection Closed"

I’ve installed Nextcloud today on a cPanel server (I do have root - it’s my server). I was able to create my admin user when I accessed the website (and set up the database).

When I installed the Windows desktop client, it’s taking me through the wizard to connect. I entered the website, and it’s able to connect - it takes me to the second page of the setup, which asks for username and password. I put in the same username that I’ve successfully used to log into the site, along with the same password. I tell it “Next”. After a few seconds, I get a red error message: “Connection closed”.

What should I do to troubleshoot this?

Use the client’s trouble shooting guide:
https://doc.owncloud.org/desktop/2.3/troubleshooting.html

Thank you for the reply, and my apologies for the delayed reply back to you.

The only useful thing I got from that guide was when going to /update.php/webdav, I get the following:

This is the WebDAV interface. It can only be accessed by WebDAV clients such as the ownCloud desktop sync client.

No prompt to log in.

I’ve installed the ownCloud Windows desktop app and am getting the same results - although there was a link to generate an app password, which I have now done, although with the same Connection closed result - I’ve tried my user password and the app password now in the ownCloud and NextCloud Windows apps…

Does it sound like webdav isn’t working, or does the above response from remote.php sound normal? Any idea if webdav works via cPanel’s setup if it should work for NextCloud?

Many thanks for any reply :slight_smile:

Hello, did you have any solution ? Wihch one ? Thanks

Have the exact same issue here.

Any ideas ?

thank you

Hi Isaac

Did you come right with this issue. If yes please help as I’ve been struggling for days now to sort this out.

Thnaks Janno

"I’ve installed Nextcloud today on a cPanel server (I do have root - it’s my server). I was able to create my admin user when I accessed the website (and set up the database).

When I installed the Windows desktop client, it’s taking me through the wizard to connect. I entered the website, and it’s able to connect - it takes me to the second page of the setup, which asks for username and password. I put in the same username that I’ve successfully used to log into the site, along with the same password. I tell it “Next”. After a few seconds, I get a red error message: “Connection closed”.

What should I do to troubleshoot this?"

Same issue here as well. I enter the username and password but it is not allowing authentication to complete.
I have tried making an app password by setting up on the Web side, but it did not work as well.
I note my web interface does not auto set to https:// and when I go to http://cloud.thathost.ca/remote.php/webdav I am prompted for a login, which I have attempted and failed. When I go to https://, I get “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”

I then tried the app on my Sony Performance X Android Phone and am also receiving authentication issues there as well. I have also tried setting up the App password for my phone and again get 401 errors after I log in. When attempting to use the “old way” I am getting Authentication Errors.

my NextCloud is set up on cloud.thathost.ca and I have set an A Record at my DNS side to point the sub-domain to that location.

HTTPS:// is setup using a LetsEncrypt Certificate

Can you login on one of the test instances? Like this, I’d rather think that’s a configuration issue on the server. Did you follow the example configuration from docs.nextcloud.com?

Hi Jason

I found my issue - Just enabled PHP-FPM on the domain in CPanel and now it works! Hope you come right!

Regards
Janno

2 Likes

How did you enable it??? thanks!

How can i enable it from the Cpanel? Please!

If anyone has any solution on how to use fastCGI and not depend on php-fpm entirely, it would be appreciated.

Perfect, it worked for me too
Thanks