Windows client asks for login credentials every time the program is started

Hi all,
since several days I’m facing a strange behaviour with my nextcloud windows client. I’m using 2.6.1stable-Win64 (build 20191105). I have configured 4 different accounts in the client. Several days ago the client started to show me 4 windows with “Browser erneut öffnen” (open browser again) and “Link kopieren” (copy link) and 4 browser tabs were opened showing “Verbinde Dich mit Deinem Konto” (connect to your account). I clicked “Anmelden” (login), provided username/password and clicked “Grant access”. For the first account this worked but when I do this for the other accounts I get the error message “Der Host verlange eine Authentifizierung” (host requires authentication) when files should be synced.
In the logfile “nextcloud.log” I found this error message:
“Exception”:“Sabre\DAV\Exception\NotAuthenticated”,“Message”:“No public access to this resource., No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured, No ‘Authorization: Bearer’ header found. Either the client didn’t send one, or the server is mis-configured, No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured”

I’ve re-installed the app with no success. After that I’ve deleted the 4 accounts and re-created them. At that point of time all 4 accounts are working. But after restarting the application the problem was there again.
I have another notebook where 3 out of the 4 accounts are also configured and I have no problem here so it seems to be a client problem?
Has anybody seen this behaviour before? What’s the best way to drill down the problem?

Thanks in advance!
Murdoc

Look in the log file for what goes wrong. See https://docs.nextcloud.com/desktop/2.6/troubleshooting.html for how to generate the log file.

Thanks for the link. I’ve done some further testing but still cant see what the root cause is. But now I can reproduce this issue. It happens at the moment when I rename a file. So I made this testcase:

  • delete all accounts from the nextcloud client
  • create a new user and add this new account to the client
  • delete all photos and documents except the file ‘Documents\Nextcloud Flyer.pdf’
  • then restart the nexcloud client with ‘–logwindow --logdebug’
  • copy the file “test.txt” to “Documents” -> successful
  • change the filename from ‘Documents\Nextcloud Flyer.pdf’ to ‘Documents\Nextcloud Flyer2.pdf’. Now the error comes up and replication stops
  • I can rename the file in the web interface of Nextcloud
    In the Nextcloud client log I cant see any specific error. If it is helpful I can provide the log via PM but will anonymize some information before.

The fact that I can create a new document shows me that the user is successfully logged in. In a second test on a different notebook with the same version of Nextcloud client I can see the same error. CREATE / UPDATE / DELETE of files work but RENAME does not. Could this be a problem with OC 17.0.1? I’m not sure how long this problem exists but only some weeks ago I’ve upgraded from 16…

Murdoc

I’ve done a test with my Android NC client and at the moment I rename a file the app crashes with this stack trace:

************ CAUSE OF ERROR ************

java.lang.NullPointerException: Attempt to invoke virtual method ‘boolean com.owncloud.android.lib.common.operations.RemoteOperationResult.isSuccess()’ on a null object reference
at com.owncloud.android.ui.activity.FileActivity.onRemoteOperationFinish(FileActivity.java:329)
at com.owncloud.android.ui.activity.FileDisplayActivity.onRemoteOperationFinish(FileDisplayActivity.java:1745)
at com.owncloud.android.services.OperationsService.lambda$dispatchResultToOperationListeners$0(OperationsService.java:727)
at com.owncloud.android.services.-$$Lambda$OperationsService$2BVgsxDpOpa4JqgzeD7OGZBLSiI.run(lambda)
at android.os.Handler.handleCallback(Handler.java:751)
at android.os.Handler.dispatchMessage(Handler.java:95)
at android.os.Looper.loop(Looper.java:154)
at android.app.ActivityThread.main(ActivityThread.java:6186)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:889)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:779)

************ APP INFORMATION ************
ID: com.nextcloud.client
Version: 30090290
Build flavor: generic

************ DEVICE INFORMATION ************
Brand: samsung
Device: klte
Model: SM-G900FD
Id: NJH47F
Product: lineage_klteduos

************ FIRMWARE ************
SDK: 25
Release: 7.1.2
Incremental: 6b703df1de

It becomes clearer now that there is some kind of incompatibility.

Murdoc