Windows client and android client fails connecting to my nextcloud installation

Nextcloud version (eg, 10.0.2): 11.0.0 although I’m trying to update to v 12.0
Operating system and version (eg, Ubuntu 16.04): CentOS 7
Apache or nginx version (eg, Apache 2.4.25): apache
PHP version (eg, 5.6): tested 5.6 and 7 with same results
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps): I can give you credentials to my hosting so you can test

The issue you are facing:

Hello guys, nice to meet you…I’m having some troubles with my nextcloud installation, I did the installation with the script, everything works so far but when I try connect my android device I get error in user or password although I can connect with the same info using the browser. I’ve tried to create new users but always happens the same

Now, the windows client show an error: connection close and I can’t login neither, I’m open to give you credentials to my server so you can check this error

The output of your Nextcloud log in Admin > Logging:

Nothing new, it shows old logs like

_Error PHP Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini and use the php://input stream instead. at Unknown#0 2017-08-16T07:36:15-0400 _

I think than these errors don’t have relationship with the issue than I’m having

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (

‘instanceid’ => ‘oc3sty…7q’,
‘passwordsalt’ => ‘O0xY+q73lpDwu0…+3gRTL8IjP6rI’,
‘secret’ => ‘KKArCmgtpfwOlyY0…Qebls+9es1cq/4rEd1s9nKR30D’,
‘trusted_domains’ =>
array (
0 => ‘minube2.<my_domain>.com’,
‘datadirectory’ => ‘/home/<my_user>/webdavfolder/nueb2’,
‘overwrite.cli.url’ => ‘https://minube2.<my_domain>’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘’,
‘dbpassword’ => ‘bayzxc_11kO_?LU’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘’ => ‘beta’, // <- I’ve changed this recently because I want test the v12 to check if the error persist
’updater.secret’ => ‘$2y$10$rz04.Fzcn.kw2tLV0AUiFeDHPAAnj2kQmqGtcffUUcYnMBeCv.SvG’,
‘maintenance’ => false,

The output of your Apache/nginx/system log in /var/log/____:

I’m using apache, would you need the error log in /var/log/apache2??..please let me know if you want review this

thank you so much guys, hope you can know what is the issue here…

I had the same issue when I tried using PHP-FPM and HTTP2. Not sure what was causing the issue but reverting to using HTTP/1.1 and MOD_PHP fixed the issue for me.

One of the possible cause that I have had no time to investigate is that, as pointed out here, the authentication headers may not be passed correctly over PHP-FPM.

Let me know if you out what exactly is causing the issue!