Windows 10 WebDAV Configuration Asking for Cert

Nextcloud version (eg, 20.0.5): 21.0.2
Operating system and version (eg, Ubuntu 20.04): FREEBSD 12.2-RELEASE-p6 (TrueNAS Jail)
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.49
PHP version (eg, 7.4): 8.0.10

Having issues connecting my up to date Windows 10 box to Nextcloud via WebDav. I am able to access the web UI just fine, and have a valid public certificate that I obtained via LetsEncrypt. When I go to map the drive via Windows Explorer, I enter the URL that is provided in the WebUI, using the same format that the documentation mentions. It asks for my password, but after entering my password, it pops up a box asking me to select a certificate.

From what I read, this is only the case when using a self signed certificate. In like manner, I did ensure that everything was added as a Trusted Root Certification Authority, as well as ensure that the BasicAuthLevel registry key is still the default of 1.

I have not been able to find anything that points to this situation, especially since that certificate prompt is usually when there is a self-signed cert involved, which is not my case.

Update: I removed all personal certificates to see if I can force password authentication and not I am getting “The Network Logon Failed” messages, or “A device attached to the system is not functioning”.

I started to investigate the actual Apache configuration files as well. I have uploaded the config files to pastebin if anyone can give them a once over to ensure I am not missing something:

Apache httpd.conf:

Includes .conf:

NOTE: I did remove my FQDN and email information for security. Thanks for anyone looking!

Hi @SteelNeo

Your VirtualHost config is missing some things when I compare it to the config in the official documentation:

Try to add this section:

<Directory /usr/local/www/nextcloud>
  Require all granted
  AllowOverride All
  Options FollowSymLinks MultiViews

  <IfModule mod_dav.c>
    Dav off

Especially the AllowOverride All directive is important, without that Apache will ignore the .htaccess file in the Nextcloud folder.

Thanks for the suggestion @bb77.

I added the changes, but to no effect. I also thing that the AllowOveride was part of the Apache HTTPd.conf file where it lists the directory options.

I am still getting the Network Logon Failed message. I downloaded a WebDAV client to try it (RaiDrive), and it seems to be telling me that the request is being aborted due to not being able to create SSL/TLS Secure channel. Wondering if there is a protocol I don’t have enabled.

Edit: I ended up downloading WinSCP and can successfully connect via WebDAV with my current configuration. The issue certainly seems to be pointing to Windows having an issue connecting to the service natively. On that note, Webclient service is running.

Not sure… I’m not really familiar with FreeBSD and iocagae, so I don’t know what specific problems might occur when running Nextcloud in a TrueNAS jail. Maybe you can search here in the forum specifically for TrueNAS or look in the TrueNAS forum. Or hopefully someone else might have some ideas…

I mainly use Linux and can’t say much about the WebDAV client in Windows. But from what I read here in the forums, it should work in general. Are you using a current Windows 10 version / build?