Windows 10 Client Sync Issues - Access denied during file rename

Running up a Nextcloud instance for the family on my homelab on my esxi server.
Installed the Vmware version of the server a couple of days ago and got that going. Created a couple of users. All good.

Installed the Windows desktop client on my notebook, ipad and iphone, all good.
Installed the Windows desktop client 3.1.2 on my desktop and it’s giving issues with most of the files.

Excerpt from the local log file:-

2021-02-12 15:10:54:612 [ info nextcloud.sync.checksums ]:	Computing "SHA1" checksum of "C:/data/Nextcloud/.vmware.txt.~2310" in a thread
2021-02-12 15:10:54:612 [ debug nextcloud.sync.networkjob ]	[ OCC::AbstractNetworkJob::slotFinished ]:	Network job OCC::GETFileJob finished for "/vmware.txt"
2021-02-12 15:10:54:612 [ debug nextcloud.sync.networkjob.get ]	[ OCC::GETFileJob::slotReadyRead ]:	Actually finished!
2021-02-12 15:10:54:612 [ debug nextcloud.gui.folderwatcher ]	[ OCC::FolderWatcher::pathIsIgnored ]:	* Ignoring file "C:/data/Nextcloud/.vmware.txt.~2310"
2021-02-12 15:10:54:612 [ debug nextcloud.sync.propagator ]	[ OCC::OwncloudPropagator::localFileNameClash ]:	CaseClashCheck for  "C:/data/Nextcloud/vmware.txt"
2021-02-12 15:10:54:613 [ warning nextcloud.sync.filesystem ]:	Renaming temp file to final failed:  "Access is denied.\r\n"
2021-02-12 15:10:54:613 [ warning ]:	"Rename failed: C:/data/Nextcloud/.vmware.txt.~2310 => C:/data/Nextcloud/vmware.txt"
2021-02-12 15:10:54:613 [ debug nextcloud.sync.database.sql ]	[ OCC::SqlQuery::bindValue ]:	SQL bind 1 QVariant(QString, "vmware.txt")
2021-02-12 15:10:54:613 [ debug nextcloud.sync.database.sql ]	[ OCC::SqlQuery::exec ]:	SQL exec "SELECT lastTryEtag, lastTryModtime, retrycount, errorstring, lastTryTime, ignoreDuration, renameTarget, errorCategory FROM blacklist WHERE path=?1 COLLATE NOCASE"
2021-02-12 15:10:54:613 [ warning nextcloud.sync.propagator ]:	Could not complete propagation of "vmware.txt" by OCC::PropagateDownloadFile(0x247df79dbd0) with status 3 and error: "Access is denied.\r\n"
2021-02-12 15:10:54:613 [ debug nextcloud.sync.statustracker ]	[ OCC::SyncFileStatusTracker::slotItemCompleted ]:	Item completed "vmware.txt" 3 8
2021-02-12 15:10:54:613 [ warning nextcloud.gui.activity ]:	Item  "vmware.txt"  retrieved resulted in  "Access is denied.\r\n"
2021-02-12 15:10:54:613 [ warning nextcloud.gui.activity ]:	Item  "vmware.txt"  retrieved resulted in error  "Access is denied.\r\n"
2021-02-12 15:10:54:613 [ info nextcloud.gui.activity ]:	Error successfully added to the notification list:  "Access is denied.\r\n"
2021-02-12 15:10:54:626 [ info nextcloud.sync.credentials.webflow ]:	request finished

It doesn’t appear to be a NTFS permissions issue, I tried :-

  • Giving my user (who is an admin) full access to the sub-tree.
  • I tried running the client as admin.
  • I gave EVERYONE modify access to the sub-tree.

My desktop is Windows 10 20H2, all the latest patches (same as my notebook)

This isn’t every file from the initial sync, about 90% of them, I’ve only got about 300meg in total, the largest file is about 100meg.

I don’t know where else to look, it should work ???

I had a similar problem like you.
The cause of my problem was, that the file was opened in another program, in my case the antivirus program (Avast).
Another Computer with the Windows Defender was not affected.
To test if yout have the same problem you could temporarily disable your anti virus program.

1 Like

thanks a lot, I always just had an “acess denied” (translated from German “Zugriff verweigert”) error without any error code, and the client worked for everyone else, so I wondered where it came from. turns out it really was avast. I guess I’ll go back to kaspersky then. hope this helps people later.