Why does the NextCloudPi docker image install NextCloud version 18?

I am curious as to why the official nextcloudpi docker images uses nextcloud version 18. Reading through the issues here and on github, it is clear that either this version doesn’t work with Nextcloudpi, or that lots of people (like me) run into problems with this old version.

After realizing that v18 was the problem, I updated to version 19 within the admin panel, which seemed to work, but then I tried updating to newer versions and at some point it totally broke. Now I need to start over again from scratch.

I chose to use NextCloudPi on a Pi with docker because I thought that this would be an easy install, but instead it has just given me grief. I would suggest to simply delete the docker images if they don’t work.

Latest ncp docker image comes with NCP v1.34.6 and NC 20 afaik. Read how to keep ncp up-to-date

So maybe you are just using an old image?

Also, and just my 2ct; Pi sucks performance wise, especially if on armv7 or below.
Pi’s are fun to play around with, get to know Linux, experiment, but you dont want to rely on harware that is dirt cheap, in the end you get what you paid for.
I’ve moved my ncp to better hardware long ago, old pi is now just running a wireguard vpn service for myself and cpl friends. Pretty stable too, it’s been running for over 2 years now, last reboot 195 days ago. so not bad for approx €30 of hardware.

I am using the latest image. You can verify by installing on a Pi using the instructions on their website:

docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi

I also tried to

docker pull ownyourbits/nextcloudpi

and it told me I was up to date.

I pushed NC21 docker images today. Note that NC lives in a volume, so you need a clean instance with a new volume to start using NC21, otherwise you need to upgrade using ncp-update-nc