Why did automatic renewal of Let's Encrypt fail?

Continued from NCP / Let's Encrypt Renewal Issue - #10 by nachoparker

Just ran into this same renewal issue on an Odroid running current 20.0.4 and 1.34.1 ncp via automatic updates + ports 80 and 443 properly forwarded along with static ip. Resolved by rebooting and then renewing letsencrypt as the automated process failed. Why does the automated renewal fail?

You are aware that the issue you linked was caused by a bug that was fixed 2 years ago? Your problem is definitely configuration issue, you do use ncp on a odroid i guess, but we need to know how you installed it and what your config is. If you manually issue a new certificate through the letsencrypt app in ncp pannel, does that work?

This problem cropped up for me yesterday. I fresh installed NextcloudPi on docker arm64 build 3 months ago for I believe first 20.0.0 release which has automatically updated since.

Following this old advice, I rebooted my system and then certificate renewal worked with no problems.

I mentioned this problem was resolved in the original post, but maybe it wasn’t clear. I fixed it by rebooting and then renewing, but do not understand why I ran into the problem. Happy to provide additional logs if they help. Cheers.

# ncp-config
Running nc-info
Gathering information...
NextCloudPi version  v1.34.1
NextCloudPi image    NextCloudPi_docker_03-16-20
distribution         Debian GNU/Linux 10 \n \l
automount            no
USB devices          none
datadir              /data/nextcloud/data
data in SD           yes
data filesystem      ext2/ext3
data disk usage      93G/117G
rootfs usage         93G/117G
swapfile             /dev/zram1
dbdir                /data/database
Nextcloud check      ok
Nextcloud version
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       ok
port check 80        open
port check 443       open