Why can I not update to v28 with the upgrader?

Nextcloud version: 27.1.5
Operating system and version: Linux 6.2.0-34-generic x86_64 (with latest stable ubuntu
Apache or nginx version: LAMP
PHP version (eg, 7.4): 8.2.10

The issue you are facing:

  • cannot update to v28
  • get nags from Passwords application that I shall update to v28

Is this the first time you’ve seen this error?
Y

Steps to replicate it:

  1. Login to self hosted NextCloud instance
  2. See updates available for all sorts of point releases but even after updating to those, no updates for major releases (in this case v28)

I don’t think I have to share config file contents or logs for this simple issue.
The system itself works fine, just that what is described here does not work:
https://docs.nextcloud.com/server/latest/admin_manual/maintenance/upgrade.html

I use the updater and I never see or saw a v28, I did not even know it existed until I got a nag from the password application in regard.
I also read that the new v28 will drop notifications for updates alltogether, which probably is not helping the situation, but I will have to live with that.

Can anyone help me how to upgrade safely to the v28? I would really prefer not to do this manually.

NC28 was just released. It isn’t necessarily available for download via the integrated Updater immediately for everyone. It rolls out in increments. About 1 in 3 installations are offered it via the Updater typically at launch time.

I have no idea what you’re referring to with the Passwords app though.

I also read that the new v28 will drop notifications for updates all together, which probably is not helping the situation, but I will have to live with that.

Not sure what you read/saw, but that doesn’t sound accurate to the best of my knowledge.

https://docs.nextcloud.com/server/latest/admin_manual/release_notes/upgrade_to_28.html

I have no idea what you’re referring to with the Passwords app though.

Passwords is an app in next cloud and on its latest update it pushed said notice that we’ve to update to v28 to keep both (passwords and nextcloud) in a supported environment.

—-

Anyway, sounds like I’ve to wait a bit and v28 will eventually appear in the updater?

Upgrade to Nextcloud 28 — Nextcloud latest Administration Manual latest documentation

That’s referring to the API used for external monitoring tools. And it’s not unavailable, just disabled by default. Unless you’re calling that endpoint from a third-party monitoring tool, nothing changes.

I guess that could be a little clearer in the docs.

Anyway, sounds like I’ve to wait a bit and v28 will eventually appear in the updater?

Correct.

1 Like

There is an undocumented way to work around staging: Merge pull request #3915 from nextcloud/enh/3908/use-correct-update-way · nextcloud/all-in-one@7c0c6d6 · GitHub

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.