Where does it download to?

and nope nothing!

what am i missing here?

you can download a file and you can go to it on your phone?

is that what is happening here?

Yes. On my phone I can see the downloaded files (the ones with a green checkmark on it), when I naviagte to Android → com.nextcloud.com → nextcloud > my account. I’m not sure why it doesn’t work on your phone…

Have you tried a different file manager other than Samsung’s? I have never liked the way they show/handle files. Solid File Explorer (link) is okay, but had ads, and there is also a Google File Manager (Files) as well. Astro is a good one too (link).

When you go into the Nextcloud app, does the photo you downloaded load in the app previewer?

The file downloads to a directory that is 50 folders in. That is the issue. Billions upon billions of websites, apps and anything downloads to the downloads folder, hence why it is called that. Putting a download 50 folders into a weirdly unknown bizarre folder is truly silly.

That is the default way how apps are supposed to store their internal files by default. The Nextcloud app is no browser and hence does not use Android’s download manager but pulls and stores files internally for offline usage. But you can choose a different folder with the app settings as shown above.

When you download files via browser from Nextcloud web interface (or elsewhere), you’ll find them where the browser is configured to store downloads, which usually uses Android’s download manager and hence most likely stores them to /Download by default.

I can understand folks might be confused by the non-intuitive download location. But I found it eventually and my local synced files.

Thank you for pointing out the app does both give that location and the option to change it. All I can suggest is if the OP can’t find them there it’s a bug particular to them or the files were not properly synced for some reason.

It would be helpful if the OP could see it that way and help us to help them.

My client’s Data storage folder is set to simply /storage/emulated/0 so my files show up under Internal storage/nextcloud/<account>/

Perhaps double check the actual setting in your client since it might be different from what others are telling you.