Where do i set max file upload

hi all,

i really dont get this, i went through all the files that nextcloud specifies to set the upload_max_filesize size but i have successfully uploaded a file thats 4GB

php.ini=2M

user.ini=511M

.htaccess=511M

cheers,
rob

ok i have figured it out but i dont know how to resolve it, when i upload a big file it takes a bit of time for it to show up on the web gui -

https://docs.nextcloud.com/server/13/admin_manual/configuration_server/caching_configuration.html

As far as i get it there are two places to add file size limitations. For once in the php.ini file of your apache server and as a second place in the additional settings of your admin account of nextcloud:
admin -> settings -> administration -> additional settings

Both should be set to the same values, for more see point 6.4 here: https://bayton.org/docs/nextcloud/installing-nextcloud-on-ubuntu-16-04-lts-with-redis-apcu-ssl-apache/

yeah the web gui admin “file handling” says 2MB and that is not correct as i uploaded a file thats 4GB so i have no idea

why are all the values i see so small but yet i can upload a massive file in the GB!!!