When using cron for background jobs, all users files in recycle bin are deleted

Hello, I apologize if I am writing in the wrong topic, this is my first question :slight_smile:
In the end of my config.php I added the following line:
‘trashbin_retention_obligation’ => ‘5, auto’,
But when I am using cron for background jobs, all users files in recycle bin are deleted (once in 15 minutes). In AJAX all work correctly. Why is this happening?

I cannot confirm this. I did a test on version 14.0.2 RC1. Created a file, deleted it. Confirmed it was in the trashbin. Waited for the next cron job. The file was still there. Which version do you run?

I am using version 14.0.1. If i delete files and then call the console command for cron: “sudo -u www-data php -f /var/www/nextcloud/cron.php”, recycle bin is now empty.
If this problem will not solved, I will simply reinstall the nextcloud and test a newer version. :slight_smile:

Also in my 14.0.1 installation this does not happen. I have

‘trashbin_retention_obligation’ => ‘auto,10’

in my config.

I think this problem is related to my local version, I will try to reinstall and check it again. Thank you.

It could be that it is a bug. I open a Ticket in August for this: https://github.com/nextcloud/server/issues/10862

I reinstalled nextcloud and I know how to repeat this bug. It only works if you are using the cron for background jobs.

  1. Install nextcloud and configure cron for background jobs
  2. Create or upload a file for testing
  3. Enable “External Storages” plugin
  4. Connect some storage to your test account (I tested with sftp/smb and local /mnt (I mounted nfs on /mnt from other server))
  5. Delete the file from where you want
  6. Run cron command in the shell: “sudo -u www-data php -f /var/www/nextcloud/cron.php”
  7. No more files in the recycle bin

This bug does not appear when using FTP and local storage (If you are mounting nfs or smb via command shell and then connect local storage, you will have this bug).