What is the local "Server Address" for Nextcloud on the phone client?

I should add: without going via apple. I just want to download them to my nice little debian box.

I got Nextcloud updated from 2 to 15. Got my web server running again. But the phone refused to connect. I realized my user on the phone had the wrong network address. Apparently no way to change credentials. (Can I just say this is one of the most frustrating installs I’ve had in years? Takes me right back to about 2003!)

So in a fit of pique, I reset Nextcloud on the phone figuring I’d just re-do that user account.

First thing it wants is “Server Address” ?? On the computer it’s nextcloud. But what does the phone expect? How can I find out what the phone thinks is the IP of the computer it’s talking to??

What’s the right answer???

All I want is to get photos off my stupid iphone!

Thanks for any help you give me, folks. I’ve been banging my head against this for two days.

Usually your nice little debian box has more than one loopback network device (127.0.01),
which you can only use if you’re working directly on your server, installed. So find out what the
ip address of this network interface is, by e.g. executing ip addr show.
Once you’ve identified that address of, e.g. device eth0, you can try to access your box using
that ip address or try to find out ts dns name, e.g. by using hostname -f or nslookup <ip-address>. If one or the other way works depends on how your network and/or dns is configured

Thanks for that! ip addr show says wlp4s0: ......... inet brd scope global dynamic wlp4s0

so I tried nslookup on and it returned:
Server: Address:

But entering either of those on the phone as the server gets me the same error message, an ssl error has occurred and a secure connection to the server cannot be made

It won’t let me use plain http. Noodling around on the web, there’s a suggestion that one can turn off the security using these lines in Info.plist:


Does that make sense? If so, where would I find Info.plist (a search of my computer didn’t turn up anything that looked relevant), or where should I create it?

Ok, it looks like you’ve several different problems on your server, a tls certificate is missing
and you haven’t integrated your server correctly in your local network so that a dns name is
assigned. Both problem cannot be solved without deeper network knowledge.
Nevertheless you can try to add the protocol to the url to get rid of the security warning, like From my experience it isn’t necessary to tweak any parameters
to access a server via http protocol

(Bah, managed to get sick. :weary: Just saw this and will try soonest.)

Back again. Well at least I get a different error message “Request failed: bad request (400)” That sounds like it’s complaining about me not having the server set up right. I’ll see what I can do to fix it. Thanks for your help!