What is the deal with the "Deleted shares"-category in the side bar

First of all, sorry if this is not technically a #support question but I do not really know where else to put this (and maybe it even leads to a bug report, idk?).

So, in our NC 19.0.10 instance, we have in the file browser left sidebar these categories, including multiple for shares. On of those is the “Deleted shares” category:


I tried to figure out what this might be. I first thought it was for when a user delete for example a folder, someone else shared with them, because in the context menu this is described as “Delete share”. But I tried this and nothing showed up under this category, when the receiving user “deleted” the share.

Then I checked if this is for the sharing user, if they remove a share, but again, nothing showed up.

So my question is: What is supposed to be listed there? Or is it one of the above and something is not working right?

Thanks in advance!

I looked at it and it seems that items in that folder are shared file/folder by other users of nextcloud that you deleted…

So, you mean, what I tried to describe here:


Because if so, nothing showed up, when I tested this: I had user A share a folder to user B. Then as user B, I deleted the share. Then I checked in the “Deleted shares”-category of user B.

//edit: I now realize, that I missed the part of “, someone else shared with them” in my original post, so this might’ve caused some confusion. My bad.

haha funny I can’t recreate it either. I have some “Deleted shares”

But can’t redo it. Maybe it’s a depreciated feature. I remember deleting this file on my side (so User B share to user A then user A delete it) but it doesn’t do it anymore…

Hmm… what version of NC are you running?

When I researched the problem I found this: No Restore button in Deleted Shares · Issue #23240 · nextcloud/server · GitHub

So this means, back in 2020 this feature at least was recognized as a working feature. So it might be a regression…

Last one nc21. But last said deleted share is from a year ago April 2020 so must have been under nc18 I believe

I also have a 20.x and 21.x available for testing. I think I will test these ones and then file a bug report for these versions…

Hello together,

nice to know that I am not the only one who runned into that :slight_smile:. After almost a year this topic still persists. Have anyone of you found an answer for this?

Thank you in advance.