What are the files (Update 24.0.2)

I have updated from version 24.0.1 to 24.0.2. Now I get this error message:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


  • openotp_auth
      • vendor/autoload.php
      • vendor/composer/autoload_real.php
      • vendor/composer/autoload_static.php
      • vendor/composer/installed.php

Can anyone help me here?
Thanks already for the support.


Please see official docs at:


1 Like

Hi rakekniven,
thanks for your answer. I saw the site. I would like to know, what App it is (openotp_auth). Is it " Two-Factor TOTP Provider"? I do not have “OpenOTP Sign” installed and get this error above…
Best regards

Please go to your app management section as admin. There you should see all installed apps.

Do you use app GitHub - rcdevs/nextcloud_openotp_auth: OpenOTP plugin enables Multi-Factor Authentication to login to Nextcloud Admin/User Pane ?

Hi rakekniven,

No I do not use Openotp. That is what I can not understand. I do not use it, but I get the error message.

I use: GitHub - nextcloud/twofactor_totp: :key: Second factor TOTP (RFC 6238) provider for Nextcloud

Best Regards


Ok, this app uses vendor libs as well. See twofactor_totp/Application.php at 3708c7bf934ff897b3fa5a39a9f1c7607d6a1caf · nextcloud/twofactor_totp · GitHub

Can you uninstall this app and reinstall?

I unistall the app and reinstalled it. But I still have the error.
That is strange (for me).

Did the error disappear after uninstalling it?
Just to make sure that we are looking for the right app.

No, the error is still there, so it must be an other app, or do I have to do something special, like reboot?

Reboot is not necessary.

So it is very strange.
I uninstalled all otp apps and I still have the issues.
So I hope it will be fixed when updates come along…
Thanks for help


1 Like

now it is solved …!:
I delete the TOTP App, and the path:


are deleted …
But the invalid hash still there … :frowning:
then I do an rescan on command line: occ integrity:check-core
now I see it was maybe a “caching thing” because now the invalid hash disappeared,
and after some reloads in the WebUI the same result: no invalid hashes :wink:

with this path I reinstall the app again,