Weiterleitung mit htaccess funktioniert nicht

Hallo zusammen,

ich habe gerade die Meldung “Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen.” entdeckt und würde das ganz gerne lösen.

Ich habe nextcloud 14.0.4 mit Apache im Ordner /var/www/nextcloud auf Ubuntu server 18.04.1 installiert.

Ich habe auch schon eine .htaccess im Ordner /var/www mit dem Inhalt:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^\.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L]
RewriteRule ^\.well-known/host-meta\.json /nextcloud/public.php?service=host-meta-json [QSA,L]
RewriteRule ^\.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L]
RewriteRule ^\.well-known/carddav /nextcloud/remote.php/dav/ [R=301,L]
RewriteRule ^\.well-known/caldav /nextcloud/remote.php/dav/ [R=301,L]
</ifModule>

Ich habe auch in den Dateien
/etc/apache2/sites-enabled/000-default.conf
und
/etc/apache2/sites-available/000-default.conf
den Abschnitt

<Directory "/var/www">
    Options +FollowSymlinks
    AllowOverride All
</Directory>

hinzugefügt.

Die Weiterleitung von https://example.com/.well-known/carddav nach https://example.com/nextcloud/remote.php/dav funktioniert aber nicht und auch die Meldung geht nicht weg. Wenn ich jedoch auf https://example.com/nextcloud/.well-known/carddav geht, werde ich weitergeleitet. Zwar auf die falsche Seite, aber es zeigt schon mal, dass die Weiterleitung prinzipiell funktioniert.

Hab das Problem gelöst, bevor ich die Frage abgeschickt hatte, aber ich dachte mir, dass das problem vielleicht noch jemand anderes hat. Also hier die Lösung:

Die .htaccess muss in /var/www/html und nicht in /var/www. Das hatte ich zuvor schon getestet, aber scheinbar war dann noch ein anderer Fehler vorhanden