Webui and tui not accessible

Hello, I was wondering if anyone cloud please help me?.. :-/… I flashed the latest bananapi nextcloud pi on too a SD card and cannot get it to work within my network, I know it works because i flashed this same device and when I ran it at work I was able to access the webui via port4443 and even configured it the way I wanted and even started loading stuff into the storage via the Android app it was working great, but when I brought it home I could no longer access the webui, I tried reflashing it and everything I know it’s up and running because I was able to jump on the terminal and I tried to access it via the " sudo nextcloudpi-config " but it returns a “command not found” then when I try to access the 4443 webui it does not allow me too I tried port 443 and even regular port 80… I’m stuck because now I can’t even activate it, i tried looking into different Linux forums but not much help… the bananapi is connected directly to my router a Netgear r7000 running the most up to date dd-wrt local DNS and everything is working fine. I even tried creating a separate mini network using a stock Asus router I had laying around to rule out any complexity but still could not connect to the webui. Please help… l


After tinkering day night and multiple tests everything is working perfect here are the findings hopefully this will be helpful to other people struggling to get this to work.

Default user is “root” pass is “1234”
Correct command if using root user is: “ncp-config” or if not then “sudo ncp-config”


If using non standard LAN range then you might have problems accessing your device specially port 4443 in my case my LAN range was, ncp did not like that or any other ranges until I used the traditional IP range.

Yes same here, tui AND webUI are not accessible, same errors as psychobilly

Any suggestions?

Found it, for me, there was no nextcloud-config. But when you open “raspi-config” the first entry is the nextcloud config :slight_smile:

At least you made the tui work… lol… I tried plugging my bananapi at a friend’s house and it works fine the webui is accessible… but the tui remains elusive… :-/…