Webdav not working

Nextcloud 11, running on Ubuntu 16.04.

I connect to my server using the DAV like this:
https://[server]/remote.php/webdav

Everyone who tries this has to enter their password twice. But after the second time I get in.

I can see my files in Windows Explorer, but if I try to manipulate them or create a new file, I get “Catastrophic failure Error: 0x8000FFFF”.

Same error on multiple machines. (Windows 10 Pro)

Webinterface login has the same error? Can you check the logfiles on your server? Do you have the same problem with a different webdav client as well (e.g. WinSCP)?

If I “add a new file”, this is the error from the log.

> {"reqId":"YQ76r3tTaiYOUiAxtxqu","remoteAddr":"10.0.8.1","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\\/1.1 500 No subsystem set a valid HTTP status code. Something must have interrupted the request without providing further detail.\",\"Exception\":\"Sabre\\\\DAV\\\\Exception\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/nextcloud\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(254): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#1 \\\/var\\\/www\\\/nextcloud\\\/apps\\\/dav\\\/appinfo\\\/v1\\\/webdav.php(60): Sabre\\\\DAV\\\\Server->exec()\\n#2 \\\/var\\\/www\\\/nextcloud\\\/remote.php(165): require_once('\\\/var\\\/www\\\/nextcl...')\\n#3 {main}\",\"File\":\"\\\/var\\\/www\\\/nextcloud\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php\",\"Line\":495,\"User\":\"FC0C1C6D-4218-4D92-8F97-37F4B652250E\"}","level":4,"time":"2016-12-28T23:38:54+00:00","method":"LOCK","url":"\/remote.php\/webdav\/New%20Text%20Document.txt","user":"FC0C1C6D-4218-4D92-8F97-37F4B652250E","version":"11.0.0.10"}

I am not clear on what you mean by Web Interface?
How can I test webdav using the web interface?

I guess the question was, if standard login into nextcloud using browser and manipulating/creating files there works without error. And if yes, if you tried to access via webdav already with different clients. But as you wrote “Same error on multiple machines. (Windows 10 Pro)” I guess you therefore tried already?

The web interface works for standard requests (not DAV). And the windows client software works.

Mapping a drive with DAV on Windows fails.

I haven’t seen this often. Can you check your webserver logfiles as well? How did you setup your system, apache with mod_php, php version 7.0? Did you add this to your apache-configuration:
https://docs.nextcloud.com/server/11/admin_manual/installation/source_installation.html#apache-web-server-configuration

There was one topic about a similar error, however no real solution (please don’t install php 7.1):

I used that doc as a guide, but you can’t follow it exactly, there are conflicts.
I’m running Ubuntu 16.04, some things are slightly different.

The sites-available/nextcloud.conf paragraph especially is confusing.
I run SSL, so my :80 site does a redirect to https://site.

The doc is not clear how to integrate those changes into the SSL.conf. It says use the default ssl conf which of course won’t work. I had to set it up with all my certificates and stuff.

Hmm interesting, I just realize that the manual wants the nextcloud.conf in “sites” folder. Mine is actually in “conf” folder, which perfectly works and also makes more sense to me, because its just not a separate vhost. I don’t know if this also works as “site” but you could try to use it as “conf”, just copy the file to “conf-available” and “$sudo a2enconf nextcloud” to enable it (or create symlink by hand to conf-enabled).

In “sites-available”/"-enabled" I use the default vhosts as expected with redirection to https in :80 vhost and certificate + strict transport security in :443/SSL vhost.

Actually I think creating the nextcloud.conf in “sites-available” folder is a mistake in admin manual.
Both ist correct. You could either do it as I described above (separate :443 vhost and nextcloud in “conf” folder) or integrate the nextcloud config parts directly into the :443 vhost, which is the expected way in admin manual. If you anyway want to enable nextcloud only via port 443, then the second option indeed makes more sense. In the end “conf” and “sites” folders are integrated exactly the same way into “apache2.conf”:

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf
# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf