Webdav locked files

Hi,

I’m facing an issue on my Nextcloud just when I try to massive upload photos from my iPhone using Nextcloud iOS client.

It start with a good speed, but after 30/40 photos the Nextcloud server stop receiving more photos and start showing a message “Webdav locker: Trying to access locked resource”.

After that I just have to cancel all files that are pending to upload because if not I constantly receive a error message “Internal server error”. Also, I can access the files that were really uploaded, but the folder that I used to upload the files will be locked as well. Because if I try to delete the folder give me error when I try it.

This only happen when I use Nextcloud iOS client, because I’ve tried from Nextcloud macOSx client and work perfectly (with more files to upload).

Nextcloud: 14.0.4
OS: Raspbian GNU/Linux 9 (stretch)
Apache: 2.4.25
PHP: 7.0.33

Anyone can help me with this error?

I already done the clean on oc_file_locks to clean all those entries, but when I try to massive upload photos from my iPhone I still have this issue.

Thank you

The locking on your normal database is not very efficient, so you should consider installing redis as filelocking cache. To reduce the effect of massive uploads, you could reduce the number of connections on the webserver …

Hi. Exact same problem here when uploading my photo library via iOS to Nextcloud installation. Webdav locked: Trying to access locked resource.

Redis is installed and is being actively used as can be shown with:
# redis-cli -h 127.0.0.1
> monitor

Tried Redis via TCP and Unix socket, doesn’t matter. Disabling locking with:
'filelocking.enabled' => false,

Immediately ‘solves’ the problem. But you’d want to leave it enabled of course. Server doesn’t seem busy at all / doesn’t run out of resources.

Any advice?

Nextcloud 16.0.1.1
Debian 9.9 fully patched
Nginx 1.10.3
MariaDB 10.1.38
PHP 7.3
Redis server 3.2.6

Does it solve?