Webdav Kalender

Hallo Liebe Community,

ich habe folgendes Problem:
Ich habe:

  • Nextcloud auf einem Linuxsystem installiert
  • Apache2 als Webserver
  • MariaDB als Datenbanksystem
    installiert. Nextcloud funktioniert einwandfrei, ich kann Daten syncroniseren und von ĂŒberall per SSL darauf zugreifen.

Nun habe ich mir die Kalender-App installiert. Dies ging ebenfalls Reibungslos. Den Kalender kann ich auch im iPhone und iPad einbinden.

Das Problem aber ist:
Wenn ich auf dem iPhone einen Termin in dem Kalender erstelle wird er nicht auf dem iPad oder im Webinterface dargestellt.
Wenn ich im Webinterface einen Termin einstelle verschwindet dieser und wird nicht angezeigt (der Kalender ist auf anzeigen, also nicht ausgeblendet, gestellt :slight_smile:).

Woran kann dies liegen?
Fehlende Berechtigungen?
Datenbankeinstellungen nicht korrekt?

Vielen Dank

mit welcher app synchst du die kalender?
und wie sind in dieser app die sync-prÀferenzen eingestellt?
darf man auf deinen kalender lesend und schreibend zugreifen?

Guten Morgen,

um mögliche Device auszuschließen habe ich mich mit meinem Admin Account ĂŒber das Webinterface angemeldet und dort versucht einen Termin anzulegen. Wenn ich einen Zeitraum im Kalender auswĂ€hle kommt auch die Frage nach Details zu dem Termin wenn ich aber einen Titel eingebe und auf Speichern klicke wird der Termin nicht erstellt.

klingt erstmal nach fehlenden schreibberechtigungen. daher war eine meiner drei fragen oben: wie darf man auf deinen kalender zugreifen?

Ich finde keine Einstellung in der ich die Schriebberechtigung verÀndern kann.
Ich habe eben im Webinterface mit meinem Adminkonto fĂŒr den Admin selbst einen neuen Kalender erstellt und dieser wird ebenfalls nicht angezeigt. Berechtigungen wurden aber nicht abgefragt.

Wo werden die Termine in der Datenbank abgelegt, evtl fehlt hier eine Berechtigung oder eine.
Ich haben mal gestest ob ich einen Kontakt anlegen kann, dies klappt aber auch nicht obwohl ein Adressbuch angelegt ist.
Gibt es eine Möglichkeit die Berechtigung der Apps selbst zu setzen?

Folgende Informationen habe ich noch gefunden:

  • Ihr Webserver ist noch nicht hinreichend fĂŒr Datei-Synchronisation konfiguriert. Die WebDAV-Schnittstelle ist vermutlich defekt.
  • Die PHP-Speichergrenze liegt unterhalb des empfohlenen Wertes von 512MB.
    Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/caldav” aufzulösen. Weitere Informationen hierzu finden Sie in der Dokumentation.
  • Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/carddav” aufzulösen. Weitere Informationen hierzu finden Sie in der Dokumentation.
  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der LeistungsfĂ€higkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen finden Sie in der Dokumentation.
  • Der PHP-OPcache ist nicht richtig konfiguriert. FĂŒr eine bessere Leistung empfiehlt es sich folgende Einstellungen in der php.ini vorzunehmen:
    opcache.enable=1
    opcache.enable_cli=1
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    opcache.memory_consumption=128
    opcache.save_comments=1
    opcache.revalidate_freq=1
  • In der Datenbank fehlen einige Indizes. Auf Grund der Tatsache, dass das hinzufĂŒgen von Indizes in großen Tabellen einige Zeit in Anspruch nehmen wird, wurden diese nicht automatisch erzeugt. Durch das AusfĂŒhren von “occ db:add-missing-indices” können die fehlenden Indizes manuell hinzugefĂŒgt werden, wĂ€hrend die Instanz weiter lĂ€uft. Nachdem die Indizes hinzugefĂŒgt wurden, sind Anfragen auf die Tabellen normalerweise schneller.
    Fehlender Index “parent_index” in der Tabelle “oc_share”.
    Fehlender Index “fs_mtime” in der Tabelle “oc_filecache”.
  • Der “Referrer-Policy” HTTP-Header ist nicht gesetzt auf “no-referrer”, “no-referrer-when-downgrade”, “strict-origin”, “strict-origin-when-cross-origin” oder “same-origin”. Dadurch können Verweis-Informationen preisgegeben werden. Siehe die W3C-Empfehlung.

tipp: zunÀchst bitte alle fehlermeldungen beheben
 und falls dann der fehler immer noch auftritt, noch mal melden.
und bitte auch bescheid sagen, wenn das problem gelöst ist.

Hallo,

ich habe in der Zwischenzeit die Anzahl der Meldungen auf:

  • Ihr Webserver ist noch nicht hinreichend fĂŒr Datei-Synchronisation konfiguriert. Die WebDAV-Schnittstelle ist vermutlich defekt.
  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der LeistungsfĂ€higkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen finden Sie in der Dokumentation.

reduziert. FĂŒr die erste Fehlermeldung finde ich keine Lösung.

Eine Eintragung im Kalender oder dem Adressbuch wird aber immer noch nicht „gespeichert“.

Gibt es noch Ideen woran dies liegen kann?

Ich brĂŒte immer noch an dem einbinden des Kalenders.
Wo werden KalendereintrÀge abgelegt? Werden diese in einer Datei auf dem Server unter dem Benutzer abgelegt oder werden die in die Datenbank geschrieben?

Die werden in der Datenbank gespeichert, nur Notizen werden als Datei abgelegt.

Guten Morgen,

ich habe den Kalender nun zum laufen bekommen.
Die Ursache war die Web Application Firewall meiner Sophos UTM. Die hat das Anlegen von EintrÀgen verhindert.

Nachdem ich in der UTM Unter WAF --> Firwall-Profil den Haken bei “HTTP-Richtlinie” entnommen habe ging es


VIELEN DANK AN ALLE UND EIN SCHÖNES FEST, vorallem an @JimmyKater fĂŒr die Hilfestellung per PN.

:grinning:

1 Like