Webdav failed because of basic challenge

Detail of my instance

  • Nextcloud version 26.0.2

  • Operating system and version: I don’t know

  • Apache or nginx version (eg, Apache 2.4.25): I don’t know

  • PHP version (eg, 7.4): I don’t know

  • Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

what I did (as explained in this docs)

  1. install davfs2
  2. add my user in davfs2 group
  3. make the dir (I tried with /mnt/dav and /home/$USER/dav)
  4. add my credential (in /etc/davfs2/secrets and /home/$USER/.davfs2/secrets)
  5. chmod 0600 both of them and only allow $USER:$USER for /home/$USER/.davfs2/secrets with chown
  6. reboot my local system (client not the nextcloud)
  7. be sure my nextcloud instance is up to date
  8. look in the forum
  9. put my password in “PASSWORD” to avoid escape
  10. I whitelisted my IP to be sure it was not block by the bruteforce

The output of your Nextcloud log in Admin > Logging:

  • NONE

NOTE:

  1. the password is a specific credentials to configure an app or device. For security reasons this password will only be shown once.
  2. when I do mount /home/$USER/dav it ask for my user then my password and I have access
  3. when I user mount -a it return this error:
/sbin/mount.davfs: Mounting failed.
Could not authenticate to server: rejected Basic challenge

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

  • Don’t have access to that

The output of your Apache/nginx/system log in /var/log/____:

  • Don’t have access to that

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

  • Don’t have access to that

ok; in the secret file: I mixed up the local user vs the nextcloud user
everything works now :wink:

1 Like

This topic was automatically closed after 12 days. New replies are no longer allowed.