Webdav doesnt work in nextcloud 11

Just did that check, .htaccess seems to be working. I got a error 500.

What kind of a system do you have (processor/RAM)? For the 500 error, what does the apache logs say?

The error500 was just because I tested if my .htaccess works. .HTACCESS seems to work all fine.

My System --> 1 x 1.90 GHz CPU, 1024 MB + 512 MB SWAP RAM, 1TB Storage HDD, debian-8.0-x86_64

There are some more things to add:

And some more things about the expected filesize-error:

My settings are exactly like “nextcloud” says they should be.

I also tried all the steps to fix already.

Can you monitor your system during the upload and see how much resources each process takes?

Hey :))

I just got it fixed by setting a different “upload_tmp_dir” in php.ini.

I set it to “/var/temp” and “chown -R www-data:www-data /var/temp/”.

Works now flawlessly, I can upload big files yay :smiley:

Are the Permissions set right? or what permissions should the upload_tmp_dir have?

I also dont understand why I had to set a different tmp_dir to get it work? Why doesnt the default one work?

Hey Greate

Nice to know

PS: in my case I haven’t enable this setting
and my /var/tmp/ has 777 -> owner root

I had a similar problem last week: Windows PCs couldn’t connect to the WebDAV link. It turned out to be a manual/on-demand Windows service (WebClient) that wasn’t’ starting quickly enough. Changing it from manual to automatic resolved the problem.


Can anyone confirm if this issue was resolved in 11.01?


Not resolve for me :frowning:

Not solved for me either

The patch I provided in the GitHub issue should fix this.

Link to the issue? Searched WebDAV and didn’t find it.

Should be this one if I’m not mistaken https://github.com/nextcloud/server/issues/2887

Thank you. So the contents of WinProblem.patch.txt go into .htaccess, but just to be certain, which .htaccess?

Text file content, for others:

— .htaccess 2017-02-03 23:35:22.941534081 +0100
+++ .htaccess 2017-02-03 13:04:56.833472230 +0100
@@ -55,6 +55,8 @@

RewriteEngine on

  • RewriteCond %{HTTP_USER_AGENT} DavClnt
  • RewriteRule ^$ /remote.php/webdav/ [L,R=302]
    RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
    RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]

The patches should be applied from the nextcloud root path.

Inserted the two lines in the mod_rewrite.c section and it’s still not working- just get repeated password prompt. Snipped and uploaded just in case I did something wrong. Have restarted Apache and then the whole server.

A fix is added for NC 11.0.3 (https://github.com/nextcloud/server/pull/3757) which is expected mid-april. There are only little changes if you want to apply the patch manually.

same problem here.
no access to webdav with NC version 11.

Please communicate if you already on a bug fix…

best regards