Webdav authentification in subfolder

Hi all,

i try a fresh install of Nexcloud 10.0.2 and i have an issue with the webdav.
i can map and access correctly to webdav and it work fine, but :
When i open a “word” document in a root directory, the document open normaly.
So, if i create a subfolder, and copy the same document in this subfolder… When i try to open this document (in subfolder), windows asking me for an user authentification.

I have an OC 9.0.2 on another server (same OS (centos 7), same php version (5.6)) and it work fine…

already tested :
-Disabled virtualhost => no change
-Replace .htaccess in the NC 10 with the “old” htaccess used on OC 9 = > no change
-Update 10.0.1 to 10.0.2 => no change
-Change rewrite engine rule (try many things) => no change.

No errors on admin page. All the other function are ok…

So any help will be welcome :blush:
thks

Upgrade to 11.0.0 and php 7.1 => no change :frowning:

Severals issue with 11.0.0 : Webdav can’t write, lot of errors on logging => revert to snapshot : (on 10.0.2).

More information :

Log (in debug mode), when openning the word document in subfolder :

Exception: {“Message”:“HTTP/1.1 401 No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is mis-configured”,“Exception”:“Sabre\DAV\Exception\NotAuthenticated”,“Code”:0,“Trace”:"#0 [internal function]: Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#1 /var/www/html/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php(446): Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)\n#3 /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 /var/www/html/nextcloud/apps/dav/appinfo/v1/webdav.php(60): Sabre\DAV\Server->exec()\n#5 /var/www/html/nextcloud/remote.php(165): require_once(’/var/www/html/n…’)\n#6 {main}",“File”:"/var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Auth/Plugin.php",“Line”:188,“User”:false}

i don’t understand this issue… What is different when i open a document in a root directory or a subdirectory ?
it’s a client side issue ? server side ?

it’s drive me crazy !

I found something… :

When i open a document in root directory, the url is : \\servername@SSL\DavWWWRoot\remote.php\webdav\document.docx

When i open a document in subfolder, the url become : https://servername/remote.php/webdav/subfolder/document.docx

So… Why ? I don’t know ??? (grrrrrrrrrrrrrrrrrr !)

This should be the default webdav-url shown in the web interface?

Do you use mod_php in the example configuration from the documentation? Please also have a look here:

Yes (according with the real name of “servername”).

and yes i use mod_php, but i don’t understand your question about this.

Sorry, I posted an unrelated link. mod_php is the default environment, it is tested and should work out of the box (https://docs.nextcloud.com/server/11/admin_manual/installation/source_installation.html#apache-web-server-configuration). If you have doubt about your Nextcloud server, you can also use the litmus checks to verify the webdav commands:
https://central.owncloud.org/t/how-to-compile-and-run-litmus-on-debian-for-webdav-tests/839

You mount WebDAV as network storage in Windows? There can be some issues related to that (other clients could be a solution here). What’s new and specific to Nextcloud are the CSFR tokens are not managed correctly by all clients (Davdroid no longer works with NC)

All of these step are verified and work fine

this issue is very strange because it’s appears only with the subfolders in webdav connection in windows 7/10.

Hello,

does anybody have a solution for this problem. It is bad if you want to open a file in subdirectory and you have to login again. We use windows 10 with in explorer mapped webdav.

I have the exact same problem at one of our customers.

Root access - no Credentials asked when opening a office document.
Subfolder - Credentials asked.

Tried setting the correct .reg for BasicAuthLevel but thats already set to “1” on windows 10.
Also installing the Certificate in the trusted root directory did not solve this issue :frowning:

There are some issue with the Windows network drive:
http://sabre.io/dav/clients/windows/

If you had it working in ownCloud 9.0 (first post), then it is a case for the bug tracker so the developers can check what broke this functionality.