WebDAV access with Docker?

One other small question - is it possible to access the NextCloud files in my docker setup using WebDAV?

I’ve tried using the URL format given in the docs:


Obviously with the server and username bits set to my local value, but it doesn’t seem to work.

Can it be done in a docker environment (Pi3 and HypriotOS) at all, and if so is there an alternative URL format needed?

in “files” if you click “settings” (bottom left) you can see your URL


please, specify NCP docker because we might miss your questions :wink:

Thanks - I thought I had tagged it as docker and WebDAV but I see I missed an ncp tag :wink: .

I saw that URL and tried it, but it doesn’t work. On my tablet’s file manager app it just gives an empty folder, and if I try it on a WebDAV app it gives a java error about security.

Based on that second one though I’m wondering if it’s due to a current lack of a security certificate on the Pi. At the moment it’s just a self-signed one, as I can’t get one from LetsEncrypt. I use a DNS service from NO-IP via my router provider (a free account), and at the moment I get an error that it’s over quota too many certificates have been provided to that domain in the given time period (I think they issue so many per week, but not entirely clear).

I’ll keep trying to get that installed anyway and see if that resolves the problem. Is there anything else that could be recommended to test? Or is there any other way to access the files like NFS or SMB locally? If so what would be the URL/URI for that?

@jimmykater - thanks for adding the ncp tag :slight_smile:

1 Like

you’re welcome @DarrenHill - i was just here and so it was a very quick one

1 Like

You should be able to access locally through the IP address, and also NCP comes with NFS and SAMBA so you can access through those, plus the web interface, plus any webdav client.


@nachoparker I have access via the local IP address via the web interfaces (both the admin panel and the user level files one) and also via the mobile/desktop apps using the local IP address.

However I don’t have any other access - WebDav doesn’t work as mentioned above, and there’s nothing via SMB from NCP (I have Samba installed in the Hypriot OS and can use that to share the USB drive’s mount point, but that doesn’t give me access to the files stored on NextCloud, just the actual installed files of the system itself (app, database, etc and ncp folders and their content and sub-folders).

I also note that a fair number of the nc- commands aren’t available in the web gui panel (e.g. the wizard doesn’t work properly as nc-automount.sh isn’t present for example, as mentioned in my other thread) and the command line ncp-config and stuff like that isn’t accessible (or do I need to attach a terminal to the container somehow for that kind of stuff?).

Is the docker container (ownyourbits/nextcloudplus-armhf) method a full install with everything, or are there bits missing going that route? The only scripts I have available are:

dnsmasq, duckDNS, freeDNS, letsencrypt, modsecurity, nc-admin, nc-autoupdate-ncp, nc-backup-auto, nc-backup, nc-export-ncp, nc-fix-permissions, nc-forward-ports, nc-httpsonly, nc-import-ncp, nc-info, nc-limits, nc-notify-updates, nc-passwd, nc-restore, nc-rsync-auto, nc-rsync, nc-scan-auto, nc-scan, nc-snapshot-synch, nc-update, nc-webui, nc-zram, no-ip, spDYN and unattended-upgrades.

From what I’ve seen on screenshots and in the documentation, I don’t think that’s a complete set is it?

The functionality is there and NCP is working at least locally (as mentioned I haven’t got letsencrypt set up yet to feel safe to open it up for external access outside my home LAN). I’m just curious as to whether I’m missing out on stuff by going the docker route?

Sorry, I forgot that you are doing the docker version. There are a few things missing that don’t belong to a container, such as automount ( thx for reporting the issue with nc-init, I’ll fix it ), or SAMBA.

If you want to use samba, you will have to do it externally to NCP in the docker version. I guess that it could be included in the docker version but at the time I thought it didn’t belong to a Nextcloud container.

If you have access to the web interface, then you have access to webdav, because it runs on the same HTTP protocol. There must be something you are not configuring right on the client.

You still have most of the functionality, and you can open your NCP docker intance to the world, use letsencrypt and such. The security capabilities are similar, such as fail2ban, modsecurity and the rest.

Docker gives you flexibility and isolation, but the SD card version is easier and more noob friendly, and also featureful because one thing is a whole OS, and another thing is a service in a docker container. Hope it makes sense.

If you feel that some information is missing / not very clear on the wiki, I encourage you to improve it. This is how it gets better every day! :wink:

@nachoparker what would be the samba path to access the files directly? As I said I have samba set up in the OS around the container, but I’m not sure where to point it as if I just point it at the mount point for the USB drive where everything’s stored I get the system level files, not the ones actually stored in the NCP.

I’ve tried webdav in Windows Explorer (Win10), File Manager HD (Android) and WebDav Nav Lite (Android) - none of them work. Windows explorer complains that the url is invalid, FM just shows an empty folder and webdav nav gives an error “java.security.cert.CertPathValidatorException: Trust anchor for certification path not found”. I’ve also tried it in Cyberduck and it works there, although it also complains about the cert first.

Hence I’m wondering if it’s all due to the lack of the LetsEncrypt cert? I’m going to keep trying to get one, but as they limit them to 20 per week per domain and mine’s a public common domain (from my router maker) there are a lot of people using that domain.

As you say it’s strange given it’s basically an extension of https, but it’s also simple for credentials and I know they’re correct (the username/pwd for my NCP user and the url from the file view webpage).

As for the wiki, more than happy to give stuff back that way once I get things fully running and I know what I’m doing more (so I can be sure I’m putting correct info in). I’m fully supportive of open source and FOSS software - already a member of Team Kodi for example :wink:

Editted to add - I’m not sure fail2ban is in the container either? I can’t see it anywhere or any menu item for it? Although I do see modsecurity there…

A bit more investigation - it works under Windows with both CyberDuck and CarotDAV, but both complain about security and the lack of certificate.

So I think that’s the root cause of everything - will confirm once I can get one from LetsEncrypt.

But would still be interested to know the correct SMB URL for direct file access in my docker configuration.