WebAuthn option doesn't exist in the settings

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2):
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0 (Ubuntu)
PHP version (eg, 7.1): PHP 7.4.3

The issue you are facing:
There is no WebAuthn option since I switched my webserver to nginx

Steps to replicate it:

  1. Install LEMP Stack
  2. Install Nextcloud (and dependencies
  3. Check the “Security” settings

The output of your Nextcloud log in Admin > Logging:
I can’t seem to find it

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '*******',
  'passwordsalt' => '********',
  'secret' => '********',
  'trusted_domains' => 
  array (
    0 => 'cloud.10meisterbaelle.de',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://cloud.10meisterbaelle.de',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '******',
  'installed' => true,

The output of your Apache/nginx/system log in /var/log/____:
I don’t know which one


PHP module bcmath (for passwordless login)
PHP module gmp (for passwordless login)

make sure the above php modules are enabled.

1 Like