Web UI not accessible when downloading a file

Nextcloud version (eg, 20.0.5): 25.0.4
Operating system and version (eg, Ubuntu 20.04): Docker with fpm-alpine
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.23.3 with Nginx Proxy Manager for reverse-proxy
PHP version (eg, 7.4): php 8.1
Browser: Firefox and Chrome on Linux and Windows

The issue you are facing:

The web UI is not responding when I am downloading a file.
The server does not seem to be responding and I am not able browse the files during the download.
I have also tried opening the nextcloud web UI with a new tab, but it is also not responsive.
The nextcloud becomes normal once the download is finished or cancelled.

I have also tried to assess my nextcloud with the Firefox’s private mode during a download in the ‘normal’ mode, surprisingly, I was able to log onto the nextcloud and was even able to download another file under the private mode. But then again, I was not able to browse the files with the private mode instance once this download has started under the private session.

I was also able to assess the web UI during a download from another computer.

I have tried tweaking the nginx and limiting the bandwidth to 20m/s with ‘limit_rate 20m;’ in the nginx proxy manager for reverse proxy. At home, download speed may get up to 30+m/s. By limiting the bandwidth, I was able to solve this issue.

But, when I was back in the office and tried to browse the files during a download, the web UI was still not responsive. At the office, the download speed may only get up to around 2m/s so I suspect this may be the issue. But, I do not want to limit the bandwidth to a value that is too low. Interestingly, after I have started a download, cancelled it and restarted the download, the web UI became responsive again with the file being downloaded at the same time.

I would like to see whether anyone has a solution or any suggestion. Thank you!

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

1. Start a download
2. Browse the files when the file is being downloaded

The output of your Nextcloud log in Admin > Logging:

I cannot see anything related to this issue in the admin log ...

The output of your Apache/nginx/system log in /var/log/____:

I cannot see anything related to this issue in the nginx log either ...

When you are in the office are you accessing NC through a domain that has an external address or directly via the server ip address?

Hi Sebastiank,

I was assessing it through the external address in the office.

So presumably it will go through cloudflare, then the nginx proxy manager with which set up my reverse proxy and finally the nginx web server for nextcloud.


So let me understand your install,

Your Domain → Cloud Flare Proxy → NC at your office or at Home?

Thanks for your prompt response, it is my first asking a question here :slight_smile:

The server is self-hosted at home. So I was accessing the nextcloud from office, via cloudflare, back to NC at home.

Thanks a lot!

Okay, do you still have the same problem if you access NC at home using just your internal IP address?

I added my local ip address to the trusted domain in config.php but could not log onto the NC with http so I wasn’t able to check whether it would work. For the nginx web server, I just used the example config,

I had searched the web to see if there is anyone facing the same problem before raising this question but could not find any meaningful result. so maybe it is not server itself. I can try using another router to see if it is the culprit.

The example file does not help.

If you are using Nginx there is normally, two config files, the nginx.conf in the /etc/nginx folder and another virtual hosts file in /etc/nginx/sites-enabled/(filename).

And you have to add a server_name (your systems ip address) or change the server_name to _ which means anything.