Web Services on Nextcloud Box not started

Hey everyone,

I’ve got a strange behaviour with my Nextcloud box I did recently reset to start up from the scratch again. After the initial setup (which went well) I did shut down the Box and after a restart there is just one service running, SSH at Port 22. None of the both webservers on 80 and 443 are active, although the service seems to be started.

Checking the services via “systemctl list-units” shows that the Apache2-service seems to be deactivated:

snap.nextcloud.apache.service loaded deactivating stop Service for snap application nextcloud.apache

while there seems to be a problem with loading kernel modules of systemd:

systemd-modules-load.service loaded failed failed Load Kernel Modules

Getting a status on this one shows:

● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2017-02-18 08:35:24 UTC; 11s ago
Docs: man:systemd-modules-load.service(8)
Process: 3901 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 3901 (code=exited, status=1/FAILURE)

Feb 18 08:35:24 nextcloud systemd[1]: Starting Load Kernel Modules…
Feb 18 08:35:24 nextcloud systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Feb 18 08:35:24 nextcloud systemd[1]: Failed to start Load Kernel Modules.
Feb 18 08:35:24 nextcloud systemd[1]: systemd-modules-load.service: Unit entered failed state.
Feb 18 08:35:24 nextcloud systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.

Can anyone help out here? I changed the internal hostname to “nextcloud” and went through the “apt-get update” and “apt-get upgrade” procedures before, at least I should mention this.

Thanks in advance for any hint,


I have the same errors on my computer now as well.

Have you tried going with the latest out-of-the-box-images at https://download.nextcloud.com/server/images/?

I figured out that the problem was with my factory images that came with my nextcloud box. After using the image for my Raspberry Pi 2 everything worked fine since then - maybe this helps you?