Web Installer does not work

I try to install Nextcloud.

I copy the setup-nextcloud.php to the web hoster (1&1 IONOS) and pointed my browser to the file.

I got:

Parse error : syntax error, unexpected ‘version’ (T_STRING) in /homepages/xx/yyyy/htdocs/cld/setup-nextcloud.php on line 394

I changed the setup-nextcloud.php (the […] is my change for a short output only in this posting):

$ diff -us setup-nextcloud.php.orig setup-nextcloud.php.new 
--- setup-nextcloud.php.orig    2019-04-14 17:06:43.409084297 +0200
+++ setup-nextcloud.php.new     2019-04-14 17:15:11.253751510 +0200
@@ -391,7 +391,7 @@
                <div id="login" class="wrapper">
                <div class="v-align">
                        <header><div id="header">
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?php echo '<?xml version="1.0" encoding="UTF-8" standalone="no"?>'; ?>
<svg xmlns="http://www.w3.org/2000/svg" version="1.1" [...] /></svg>
                        </div></header><br />

If I pointed to the new version I can click on “Next” and the only result is that a “?step=1” is appended to setup-nextcloud.php but nothing else happened.

In former day this kind of installation works on this website - with an old version of owncloud (I have found no new web installer on their website).

TIA Klaus

I was having the same error a few days ago. Maybe try the zip/tarballs from the website as these worked perfectly for me