Web Hosted installation - Client Setup

Hi everyone, I’m a noob when it comes to NextCloud but I like what I have seen so far.

I have setup and installed the system behind a website, I am able to log in to the website without any issues, but have problems when I try and connect a client.

I get the basic pages in my browser about logging in etc then I I discover that the client application has failed to connect with the followin message in the connection wizard under the server address box:

Server replied “403 Forbidden” to “PROPFIND http://websitedomain.co.uk/nextcloud/remote.php/webdav/

I have no idea where to start looking with this message.

Any help would be appreciated.

Regards

Steve

  1. It seems that the given url is a place holder for your real domain, right?
  2. Please tell us how you’ve configured the “trusted_domain” parameter in your Nextcloud configuration.
  3. Are there any related log entries in the webb server or Nextcloud log file which might help identifying the root cause of the problem?

Hi,

Thanks for getting back to me. Between my posting and your reply I have rebooted my PC and the message has changed!

“There was an error accessing your ‘token’ endpoint:
Error transferring http://domainname.co.uk/index.php/v2 - server replied: Not Found”

The error message in the server logs says:

  • [06/Oct/2020:18:18:43 +0100] “GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1” 200 335 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0”

Thanks again

Steve

The first url differs from the one in the log file. I would assume that you’re rewriting the Nextcloud url somehow which results in an invalid url. “.../index.php/v2” is definitely not a valid Nextcloud url.