Wasabi external Storage - Subfolder directory not visible

I integrated Wasabi external storage with Nextcloud successfully. The subfolders list is visible in Nextcloud. When I upload data in Nextcloud, that is visible.
on the other side when I upload data in Wasabi, it does not show in Nextcloud.
Also the primary folder list that is available in the nextcloud, does not show the subfolders and the data in them.

When the integration was one, there was the Green Tick to ensure that everything is done successfully. But doesnt seem like it is working properly as the data is not visible.

Any solution to this problem?
This is the solution that I need for the thing I am trying. A little solution to this would do me a huge help.

Thanks

You answered your question yourself. How should Nextcloud know anything about files which have been uploaded on an external storage without setting access rights correctly and forcing a Nextcloud file scan?

Please read the following paragraph of the Nextcloud adminstrator guide:

https://docs.nextcloud.com/server/20/admin_manual/configuration_files/external_storage_configuration_gui.html?highlight=files%20scan#configuring-external-storage-gui

And/or search the forum for related information:

https://help.nextcloud.com/search?q=occ%20files:scan

Hello @j-ed.
Thanks for the response.

I worked on that and was able to sync it properly. Thanks for the information.
Small set of data is synching and uploading easily in Wasabi and is visible in NextCloud.

Now, the moment I try and send a big data set to be uploaded i.e. 30MB or more, it uploads on Wasabi(which it should with no problems) but does not sync onto NextCloud.

So small subfolders are visible but NextCloud is not able to sync the larger folders.

Any idea on how this issue can be sorted?

As I already wrote, run the occ files:scancommand on your external drive. Due to the fact that you didn’t provide any error messages are log file excerpts I assume that you didn’t run that task yet.