Warning! The Document could not be saved

There’s been a few others across the internet and in this forum that have experienced this issue.

Basically, I used this link https://www.linuxbabe.com/docker/onlyoffice-nextcloud-integration-docker to install NextCloud and OnlyOffice side-by-side using Docker and Docker-Compose. The only differences were in the Docker Compose install commands (the ones supplied aren’t correct and only retrieve HTML according to another article) and I have my domain named points to the IP address as a trusted domain. This is all on Ubuntu 17.10

Everything works fine, EXCEPT when you create and/or open a file, you get the following pop-up error:

“The document could not be saved. Please check connection settings or contact your administrator. When you click the “Okay” button, you will be prompted to download the document. Find more information about connecting Document Server here.”

After clicking “okay” and closing the save menu, you can STILL work on and save in the document.

I’ve tried a few things, but fairly new to all this, so not sure what to do, though my settings within NextCloud OnlyOffice section are the default ones.

A comment on this page: https://disqus.com/home/discussion/linuxbabe/how_to_integrate_onlyoffice_with_owncloud/#comment-3208443793 has the following:

“Since the two servers are in the same network, but the network doesn’t have a DNS server (just using Google’s), I had to enter the ONLYOFFICE server IP and domain name in the hosts file on the ownCloud server, and the ownCloud IP and domain name in the hosts file on the ONLYOFFICE server. I had made the entry on the ownCloud server from the beginning, but I didn’t figure out I had to do it on the ONLYOFFICE server as well until just now.”

Which sounds great! But I’m not 100% sure how to do this, even after messing around.


User talked about two separate servers in one local network. In your case you use docker containers. Document Server cannot save the file because the URL (where it should save) is wrong. Did you install SSL certs? If you did you should know that SSL certs should be installed on both servers (Nextcloud should accassible via HTTPS and Document Server should be accessible via HTTPS). Also i just install on my server to test and it works perfect

I suppose you should search your problem in connection between containers.

Also what are your current settings in Admin panel for

  • Document Editing Service address
  • Advanced server settings

That makes sense, as I only set SSL via ngnix per that tutorial. How do I set the SSL certs for both? Can I copy over the ngnix code lines to a different file?

Here’s my settings in NextCloud, which were the default:

Can I get a bump?

After lots of messing around, I was able to resolve this for our setup. First, I put the generated certs in a certs folder under the app_data > data folder for our docker volume. Then I added https: for https://nginx-server/ to our Server address for internal requests from the Document Editing Service under admin. Previously, it was set as the default http.

Hello, I have exactly the same setup since I used the same installation tutorial, and Im experiencing the same problem.
Could you please give me more details about how you solved it ? I used the certificate generation in the tutorial, but when I had https for the nginx-server I still get the same error.

@bobble, I tried understanding what you mean and translate it into the following steps:

  1. Access docker volume for nginx
    sudo docker exec -it nginx-server bash

  2. Go to data folder
    cd /var/www/html/data

  3. Create ‘certs’ directory
    mkdir certs

  4. Copy SSl certificates into it:

cp /etc/letsencrypt/live/cloud.example.com/fullchain.pem /var/www/html/data/certs

cp /etc/letsencrypt/live/cloud.example.com/privkey.pem /var/www/html/data/certs

  1. Go to Nextcloud settings page >> Administration >> ONLYOFFICE and replace http://nginx-server with https://nginx-server

However, the result when I try to click “Save” on step 5 above, I get the following error message:

Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.)

…and now, I can no longer create document/spreadsheet/presentation from Nextoffice Files app… :frowning: