Warning about mailserver config after Update to 23.0.3

Nextcloud version (eg, 20.0.5): 23.0.3
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.53
PHP version (eg, 7.4): 7.4

The issue you are facing:
after updating to 23.0.3 I get the following warning about my configuration:

Du hast Deine E-Mail-Serverkonfiguration noch nicht festgelegt oder überprüft. Bitte gehe zu den Grundeinstellungen , um sie einzustellen. Verwende anschließend die Schaltfläche “E-Mail senden” unterhalb des Formulars, um Deine Einstellungen zu überprüfen.

I think this is a new check to make sure mails can be send out correctly. This may surely be useful for people HAVING a mail server running.
But as nextcloud is also a popular software to run at home, this does not really make sense for many people. Configuring a mail server at the home network is hard and not really viable because residential IPs are mostly blocked by mail providers anyways. So those home users get the feeling that there is sth. wrong with their setup, even though the current mode is actually right for them.
I think a toggle option in the mail settings under /settings/admin would make sense here. And if the admin says "no mail server configured/needed a warning could be a displayed there in the mail settings like

Nextcloud can not send mails e.g. for password resets

But then disable the check & warning in the general /settings/admin/overview

Is there a way to disable certain checks already? (without breaking integritychecks)
(would still prefer an option since I think this will be useful for many people)

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. not configure mail settings under /settings/admin
  2. update nextcloud to 23.0.3
  3. check /settings/admin/overview

Hi @STonEDSTonE

You don’t have to run your own email server in order to use this feature. You can use any email service, that allows third party clients to connect via SMTP. Just add the connection details and login information of your email account to the “Email server” settings, as you would do it in any other email client.

1 Like

@bb77 oooh I didn’t even think about that, thanks mate!
I configured it with my private mail adress and after some issues with the configuration (a space character after the SMTP server name, didn’t see that when I copied it) it works.

1 Like

what if I don’t want to set up the mail server and get rid of the warning ?

1 Like

Change “Send Mode” to “Sendmail”, “Sendmail mode” to “pipe (-t)”, leave “From address” emty and hit “Send email”. Worked on my test instance, where i don’t need notification emails.

where should i configure it? is it in config.php?

I did this in the web-ui.

how to change send mode to sendmail ? can you show your config on ui

the input field for “Send mode” is a dropdown menu. Just click on it and choose sendmail. And the click on the “Sendmail mode” filed and choose “pipe (-t)”.

2022-03-22_10-45

This is just a simple workaround I used on my test instance. And it makes the warning disappear for me. I don’t know if you can disable the check, or even remove the email settings completley, which would probably be a cleaner solution.

1 Like

i think the options in the UI are dependent on what is available on your system. So the sendmail option only shows up if you already have sendmail installed on the system.
Installing sendmail just to get rid of the warning also seems overkill. My solution (using one of my private emails since i have a home family setup) was the least effort in my opinion, but if you do not want to use your private email adress (as you may have to store your password for SMTP authentication there as well) I would rather register a new free mailadress somewhere, configure SMTP with it and then leave it be instead of running an additional service (sendmail) on my system. But thats just my opinion :slight_smile:

But if you really don’t want to use that feature at all, you could also just ignore the warning. After all it’s just a warning or a recommandation what you could do. It’s not an error message that necessarily requires you to take any action.

1 Like

I hear you bb77. It’s… my human failing that I cannot ignore warnings like this, so I’m adding my name to the request to “silence” specific warnings, or have a simple “don’t use email on this server” checkbox.

2 Likes

@hardingtnextcloud haha i have the same issue, if there is a warning it must be perished :stuck_out_tongue:

2 Likes

This would of course be the ideal :slight_smile:

2 Likes

Post #9 worked for me… Thanks

I’m with the rest of you who can’t stand warnings (benign or not). This really should be set to disable w/ a check box.

1 Like