Very slow write speeds with ISCSI Target as Storage

Hi, I am currently facing an Issue I need help with.

Before I get into it i will quickly specify the system I am running on.

Raspberry pi 4 with 4GB Ram, PHP-8.1, NGINX (self compiled with ModSec plugin), latest stable Redis and MariaDB.

And now my problem: I was switching from a USB HDD as Storage to an iSCSI target on my NAS.
Now I am having increadibly slow write speeds but very high read speeds ( With files over 1 GB), so the network is not at fault. I tweaked the PHP and NGINX setting. Basically I tried every possible combination of this documentation :

If i set max_chunk_size --value to 0 it uploads extreamly fast, but then cant process the file and after ~ 1 minute it throws the error “connection to server lost”. I changed the tmp dir to one on the ISCSI target with enough storage, but this didnt help. Maybe I forgot a timeout value somewhere?
I also tried to disable Modsecurity, but now my uploads buffer at 512 MB.

Any Ideas on what I could try?

Do you mount the storage or do you use the external storage plugin?
Not sure, how these remote file transfers are cached (if they are). Perhaps monitoring tools can help you to check which resource (CPU/RAM, network, file-io) is restricting you. I’d also try to check the performance of the write speed on your network storage without Nextcloud.