VBox lost power, problems with next cloud on re-boot


#1

Have (Or had) Nextcloud running well Virtual box…

HostOS Winblows 10 had an update which I missed, and re-started without my permission…

On startup, all looked well. Logging in to NC, had the .ocdata file missing,
did a
touch .ocdata
than chown www-data:www-data .ocdata
was able to log in…

See the red x, and know somthings up…

did the www-data:www-data /usr/bin/php /var/www/html/nextcloud/occ flles:scan --all

Some users are ok, some are giving me
Home storage for user me not writable

So, did a sudo chown -R www-data:www-data /media/mymount/nextcloud/data

Still no luck…
windows shows, mypdf.pdf - server replied: Forbidden (Sabre\DAV\Exception\Forbidden)

NC log has
Sabre\DAV\Exception\Forbidden:

  1. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1096: OCA\DAV\Connector\Sabre\Directory->createFile(‘5637-104 Halsey…’, Resource id #72)
  2. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 529: Sabre\DAV\Server->createFile(‘files/glenn/Own…’, Resource id #72, NULL)
  3. [internal function] Sabre\DAV\CorePlugin->httpPut(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
  4. /var/www/html/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
  5. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method PUT’, Array)
  6. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
  7. /var/www/html/nextcloud/apps/dav/lib/Server.php - line 287: Sabre\DAV\Server->exec()
  8. /var/www/html/nextcloud/apps/dav/appinfo/v2/remote.php - line 35: OCA\DAV\Server->exec()
  9. /var/www/html/nextcloud/remote.php - line 164: require_once(’/var/www/html/n…’)
  10. {main}

UPDATE…

viewing the data dir in windows, there are a bunch of folders (for each user) but in the guest os,
doing a cd /media/mymount/nextcloud/data and than
ls -a shows
. … appdata_ocuoe94q340h files_external me nextcloud.log .ocdata

So, it looks like the guest OS, cant see all of the folders to begin with… Hmmmmm

Any ideas on where to start ?


#2

Found the problem, had to do with guest additions…
Looks solved, thanks…