V23.0.0 no NC Office, no backups

Hello,

Nextcloud Version: Nextcloud Hub II (23.0.0)
Server: Ubuntu 18.04
Webserver: Apache v2.4.51
Nextcloud works fine except some update features.

i installed the version 23.0.0 with the beta channel.
Everything works fine except the custom menu.

But the problem because i write this post, i dont have the announced Nextcloud Office and the backup function. I dont find anything like that. And if i click on a office file like a word document, it just download the file and not open it in nextcloud.
But other problems like the profile page works.

I hope anyone can help me.

Kind regards,
Timo // NiceKype

How did you install it? Did you download the tar file from website and installed it?
Or did you use the VM?

Please provide details.

Have you installed the office and backup apps?

I installed the backup with the installer in nextcloud itself of course.
I simply switched to the beta channel to get the update and and then installed it there.

How did you Nextcloud itself?

… → Nextcloud internal installer. Nextcloud installed it by itself. Thats what that says

not sure if it’s related but i have the same problem. i did a fresh install of nextcloud 22 onto a test server and upgraded it to 23.0.2 tonight. i can’t use nextcloud office at all. when i click on any document it wants to download it.

if i create a new document it creates it as an .odt and then prompts me for the template. i then get the popup message: “Unable to create new file from template”

the document is created but i can’t do anything with it.

the logs do show something very useful, however:

{"reqId":"mejCJP81F8EH2Fwzh7n8","level":2,"time":"2022-02-17T11:58:14+00:00","remoteAddr":"192.168.243.2","user":"admin","app":"no app in context","method":"GET","url":"/core/preview?fileId=4948&c=6a405799e7a2a4afbb3f1ab71b230613&x=250&y=250&forceIcon=0&a=0","message":"Host 192.168.80.92 was not connected to because it violates local access rules","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0","version":"23.0.2.1"}
{"reqId":"mejCJP81F8EH2Fwzh7n8","level":3,"time":"2022-02-17T11:58:14+00:00","remoteAddr":"192.168.243.2","user":"admin","app":"core","method":"GET","url":"/core/preview?fileId=4948&c=6a405799e7a2a4afbb3f1ab71b230613&x=250&y=250&forceIcon=0&a=0","message":"OC_Image::fixOrientation(): No image loaded","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0","version":"23.0.2.1"}

192.168.80.92 is the ip address of my test nextcloud server. 192.168.243.2 is the ip address of my workstation.

“Host 192.168.80.92 was not connected to because it violates local access rules” seems fairly significant. i tried searching through the forums here but couldn’t find anything.

unfortunately i do not know whether this issue existed with 22 prior to upgrading to 23 (i was mainly focusing on nextcloud talk testing in this release and never launched a document), but i’m guessing there is some configuration somewhere which needs to be altered.

is someone able to guide me in the right direction?

cheers, wizdude.

@wizdude
Have you installed and configured the needed apps?
Watch this video.

that video is for collabora online. i’m using Nextcloud Office which came pre-installed with groupware setup in Nextcloud Hub.

i have Nextcloud Office 5.0.2 and Collabora Online - Built-in CODE Server 21.11.03 installed.

collabora-server-online

given the error i received in the logs, i’m sure there must be some config somewhere that is not accepting the connection. is there some advanced config where i should be putting in a hostname for the built-in CODE server?

this is so strange. the issue appeared to be browser related.

i was playing around with the nextcloud config file to try and deal with the error from the logs, but then i tried accessing it using Chrome on my work pc - worked fine. Tested from Firefox on my home pc - worked fine. Tested from Firefox on my office pc - failed.

restarted firefox at the office - problem gone.

the only thing i don’t understand is that i first encountered the problem on firefox at home which is still open and still running - and suddenly it’s all good.

based on the fact that the browser wanted to download the file rather than launch nextcloud office, could this be due to a session/cookie thing with the client? i would have thought that if i was offered the file that the server made this decision.

here are all the steps in my testing:

  • restarted server - no change from firefox
  • edited config.php and added 2 => ‘192.168.80.92’, into the “trusted_proxies” array and restarted apache - no change from firefox
  • edited config.php and added ‘allow_local_remote_servers’ => true, and restarted apache - no change from firefox
  • removed all these changes and reverted back and restarted apache - no change from firefox
  • tried from chrome at office - working
  • tried from firefox at home - working
  • tried from firefox at office - failing
  • restarted firefox at office - working

the bit that mystifies me is that it was initially failing from firefox at home, and i didn’t touch this browser and now it’s ok.

something got cached somewhere - but i’m not sure what.

i guess the issue is resolved unless i can somehow reproduce it again the future.

cheers, wizdude

Hello,

I have the same versions running as you and every time I reboot my server I cannot edit office files as well. It prompts to download them. Here is my workaround:

  1. Go to global settings
  2. Go to Nextcloud Office
  3. “Use the built-in CODE …” is selected.
  4. Toggle to “User your own server” and back to previous selection
  5. It works to edit files using Office in the browser

Tested with ff and Safari.

Maybe that helps you.

do you need to do this every time you reboot your server?

Yes, that happened some weeks ago. Cannot remember which app update started this behavior.

Does my workaround work for you?

I’m having the same issue. I tried rakekniven’s workaround, but it did not work for me. Any other solutions to this?