Using the external URL instead of internal IP in links in welcome email

Hello everyone,

we’ve set up NextCloud on a server in our LAN and it seems to be running fine so far. We were able to create shares, users and groups and even managed to make it accessible over the internet. Using the NextCloud app is working as well so we are quite happy about it!

There is one problem though which we can’t figure out and I haven’t found a post about it in the forums:

When you create a new user and leave the password blank it’ll send a welcome email to that user asking him/her to set a password.

Now the problem is that the link itself is always linking to the internal IP address of our server (example: but I would like to have it link to the external URL (example:

So far, every external user that we are inviting will get the invite email linking them to our internal IP and thus can’t access it.

Is there an option somewhere (or a template) where I can edit the link generated in the welcome email? So that it goes from to

Thanks a lot, your help is appreciated! :slightly_smiling_face::+1:

I think you shoul logged in via the external adress an then make a new user

and did you check Preferences theming (/index.php/settings/admin/theming) the address?

Hi Norry, interesting… logging in using the external address already did the trick! Thanks!

The URL in admin/theming was already set.