Users are not listed

Trying to browse Users results in following error:

One of the user tried logging in, results in “internal error”

Logging has following error:
Exception: Call to undefined method OCA\Maps\Service\PhotofilesService::safeDeleteByFolderIdUserId()

Nextcloud version is 17.0.2
Ubuntu 18.04
PHP 7.3.14
Apache 2.4.29

Full log from admin logging:

[no app in context] Error: Exception: Call to undefined method OCA\Maps\Service\PhotofilesService::safeDeleteByFolderIdUserId() at <<closure>>

0. /var/www/nextcloud/lib/private/AppFramework/App.php line 126
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\Provisioning ... {}, "getUsersDetails")
1. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
   OC\AppFramework\App::main("OCA\\Provisioni ... r", "getUsersDetails", OC\AppFramework\ ... {}, {_route: " ... "})
2. <<closure>>
   OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: " ... "})
3. /var/www/nextcloud/lib/private/Route/Router.php line 297
   undefinedundefinedcall_user_func(OC\AppFramework\ ... {}, {_route: " ... "})
4. /var/www/nextcloud/ocs/v1.php line 82
5. /var/www/nextcloud/ocs/v2.php line 24

GET /ocs/v2.php/cloud/users/details?offset=0&limit=25&search=
from :

I’ve not attached other logs required, because I didn’t see any errors in them

sudo -u www-data php occ user
commands work without any issue

Things I’ve done recently:
restore default for all theme related options, disable password app

Did you try to disable maps app?

Actually forgot to mention: maps app was showing update available but update would never go through, kept giving error.
I updated maps app with solution from github


Yes, but did you try to disable it anyway? This might help.

1 Like

Solution mentioned is disable maps app, update manually and re-enable.

Also just checked apps folder and updated maps app has different permissions than others:

drwxrwxr-x 1 www-data www-data 282 Jan 17 16:43 maps
drwxr-xr-x 1 www-data www-data 66 Jan 17 21:09 event_update_notification
drwxr-xr-x 1 www-data www-data 100 Jan 20 20:02 calendar

Sorry for asking so persistently, but did you try it while the app was disabled?
There seem to be issues with maps even after the update.

I’m sorry if I’m not understanding it correctly.
I’ll try to give kind of chronological steps:

  1. Nextcloud instance showed notification about maps update available.
  2. I tried updating by clicking on notification, that didn’t work (gave an error)
  3. Searched around and found github issue
    Used the solution mentioned:
sudo -u www-data php occ app:disable maps
cd apps
mv ./maps ./maps-old
tar -xzvf maps-0.1.4.tar.gz
chown -R www-data:www-data ./maps
cd ..
sudo -u www-data php occ app:enable maps

During this process I didn’t access maps app.
I didn’t put instance in maintenance mode because it was taking only few minutes
so I’m not entirely sure if other users were accessing maps app

  1. Restored theme related settings to default because icons were not showing correctly.
  2. Noticed User issue.

Please let me know if more details are needed.

Or if you meant did I try disabling maps app after update then I didn’t.
I’ll try that right now

1 Like

Yes, that was my intention.

1 Like

I’m sorry took me a while to understand it.
But yes disabling maps app worked to get Users listed.
I’ll check with particular user if it resolves their login issue.

Thanks a ton

Glad to hear this helped you :+1:
If you experience sudden access problems to nextcloud it is always worth a try to disable the last updated apps, and if you don’t know which disable them all, try again and if it works enable them one by one until you find the “black sheep”.

EDIT: If you really need maps, you might consider downloading an older release from github and installing it manually.

1 Like

Don’t really need maps, will leave it disabled for now. I’ll try again once I get hub (18) update