UserId sometimes case sensitive, sometimes not

Hello, I am currently evaluating nextcloud as a collaboration tool for leaders of a scout group. I have used the user provisioning api to import all my users, I have registered in another database including there email into owncloud. That worked so far. The old database was not case sensitive in terms of the username. So the current usernames are looking like MaierM or at the moment. The users are used to that and they are using sometimes the mixed capital or only a lower case version of the username. For the normal login this can be done also in nextcloud. So he can login as MaiaerM or as maierm. But when using the lostpassword function the user gets the message that he has no email address present in his profile when using maierm as a username.
When using the MaierM as username he gets the lost password mail.
I tried to change the collation of the two database tables oc_preferences and oc_usesr from utf8-bin to utf-unicode-ci but this did not change this behavioud
I believe nextcloud should be consistent in that. So either the userId is always considered as being case sensitive or never.

The password reset link from the email is also not working.
I get in the browser console the following javascript error:

Refused to connect to ‘http://xxxxxx.de/index.php/lostpassword/set/fU4kPNv2eJCEPSD6LOM1s/LohwasserW’ because it violates the following Content Security Policy directive: “connect-src ‘self’”.

in google chrome

That is an old issue with many many duplicates:

OK, this seems to be this issue in the bug tracker.
So this will be fixed in future version I suppose?

What is about the second problem I mentioned.
I should raised a second thread for it. Sorry.

But On my installation definitely the the password reset dialog is broken. I get in the browser jvascript console the error message:
Refused to connect to ‘http://xxxxxx.de/index.php/lostpassword/set/fU4kPNv2eJCEPSD6LOM1s/LohwasserW’ because it violates the following Content Security Policy directive: “connect-src ‘self’”.

when the user clicks on “Passwort zurücksetzen” (Password reset) button

OK, I found the issue. The password rest link which owncloud generated was http:// protocol and the site is running https. This maight be caused by the fact, that I am proxying nextcloud.
So I put ‘overwriteprotocol’ => ‘https’ into my config and everything is working as expected.

1 Like

Glad you found a solution! How’s everything going for you now?