User1 cannot open PDF file shared from files by admin => Misconfiguration Or Bug?

Nextcloud V21.0.1 on Debian Turnkey OVA &
Nextcloud V21.0.1 on IONOS Webspace
Same behaviour:

Scenario to be replicated:

login as Admin
Create a Group → WIR
Create an User → User1
Assign User1 to Group → WIR
Go to Deck
Create a Deck → Nextcloud
Share it with Group → WIR
Go to Card → Details
Go to → Attachments
Click → Share from Files
Navigate to Documents
Choose → Nextcloud flyer.pdf
Click on the file just shared
=> Opens up = OK

Open Nextcloud in another Browser
login as User1
Go to → Deck
Choose → Card1 → Details → Attachments
The file: Nextcloud flyer.pdf can be seen
Click on the file to open!
=> NOTHING Happens!

BUG? or Misconfiguration?

Can You Pls. be so kind and follow this scenario on Your Nextcloud and comment?

@stefan-niedermann could you chime in here, please?

Unfortunately i don’t know much about the attachments handling of the Deck server app 1.3.x, but there has been an issue opened in the corresponding repository (Upload a *.pdf File to Deck / Card / Attachments · Issue #2997 · nextcloud/deck · GitHub) and since @juliushaertl already read it, chances are better to get an answer there than here.

@stefan-niedermann thank you very much for your precious comment, clearing up things a bit.

referring to our own definition on the forum an existing github-issue will lead to a “solved” checkmark here since usually there’s nothing more we could do.

though this thread will stay open and so the problem could be discussed on if neccessary

I think it is a necessary function when try to have a productive workflow in Deck.
What do you think?

I assume that you have a Nextcloud with the correct configuration.
My question is now:
Is the described scenario reproducible on your correct installation of Nextcloud?

If NO and it works in your setup - I can start looking for my miss configuration or see if other APPs are causing the malfunction etc…

What is Your Idea of checking this issue?

PS: I thought it is a good Idea to ask other Deck users

on their Experience with Deck and have a maybe quick comment that this described scenario works or other hints, how they maybe solver it,
BUT You closed it. :frowning_face:

THX for taking care!
The issue can now be seen here:

What are the further steps for me to get this solved?
(it’s the first time for me can you pls explain?)

Can I help somehow testing the solution?

Just wait a bit. The link points to a so called “Pull Request”. This means the app author has changed the code so the error does not occur again.
This code change will be published with the next version. So all you have to do is to wait and update your Deck version when an update is available.

THX for Your reply
I found this:

Does it mean I can download the fix somewhere and install it to have the issue solved?

You can, but i do not recommend this. This is for users with advanced tech knowledge and can break even more if you don’t know what you are doing.

I recommend you to wait for the official update and just update the Deck app as soon as it is available.

To All involved!
Its solved #3040