User_saml under nextcloud 10

i have activated user_saml in addition to user_ldap in Nextcloud 10.0 (stable) and I still get this error: "invalid_response Not authenticated"



The same configuration works in Nextcloud 9
Thank you in advance

@LukasReschke any clue?

Hi @rullzer thanks. It works now. It was a format error of my “sp-x509cert”

Hi,
I am facing the same problem, could you tell me how did you solve it and what do you mean by format error “sp-x509cert”.
Because I checked the database for the sp-x509cert value and it looks fine, but when I run the config:list command from console I see the sp-x509cert value is set with additional new line character “\n” and backslash.
Strange enough when I run the config:app:get user_saml sp-x509 the value appears exactly like the one in the database.

Thank you

Hi,

i had just forgetten to write the final line “END-CERTIFICATE”.

Hi,
Thanks for the respond. But still the same problem.
I traced the code and this error occurs when the saml respond is invalid
SAMLController.php line:154.
And the documentation about user_saml app is really poor.

@LukasReschke could you please help?