User-ID instead of name

Hello,

I have setup NextCloud 12 and I need to config user LDAP connexion.
all seems OK.

However, when i going on users, there is User-ID and not the real name.

Any Idea Please ? :slight_smile:

Well i guess you have to show us your ldap settings.

User Display Field Name might be of interest.

Taken from https://docs.nextcloud.com/server/12/admin_manual/configuration_user/user_auth_ldap.html

and i have this in log :

no app in context	Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route "theming.Theming.getLogo" as such route does not exist.	2017-07-27T16:46:07+0200

Error no app in context Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route “theming.Theming.getLogo” as such route does not exist. 2017-07-27T16:45:57+0200
Error PHP ldap_control_paged_result_response(): Result is: No such object (32) at /var/www/html/nextcloud/apps/user_ldap/lib/LDAP.php#74

Do you have a field “displayName” on your LDAP Server? I have “cn” on this setting.

No problem on displayName.
There is a problem on User Name (Login) and i don’t find where config this field

Thanks for your support :slight_smile:

i think i have found the problem,
i have not the sAMAccountName Attribut :frowning:

no sAMAccountName :frowning:

@illuzion you only need put SamAccountName on Internal Username Attribut on Expert

I hope it helps you…

2 Likes