User Accounts nicht mehr funktional nach Move auf einem neuen Server

Hallo Community,

ich habe einen Nextcloud von einem alten Debian 12 Intel i7 Server auf Proxmox VM (Debian 12.5, Kernel 6.5.0-0.deb12.4-amd64) gemoved, aber nun scheinen meine User Accounts nicht mehr zu funktionieren. Nexcloud Login Screen erscheint, gebe dann die Credentials ein, dann Server Error:

Interner Serverfehler
Der Server konnte die Anfrage nicht fertig stellen.

Sollte dies erneut auftreten, senden Sie bitte die nachfolgenden technischen Einzelheiten an Ihren Server-Administrator.

Weitere Details können im Server-Protokoll gefunden werden.

Technische Details
Entfernte Adresse:
Anfragekennung: Fd6nTJJdCXr8sNWori70`

Meine Config:

sudo -u www-data php /var/www/html/nextcloud/occ status

  • installed: true
  • version: 29.0.1.1
  • versionstring: 29.0.1
  • edition:
  • maintenance: false
  • needsDbUpgrade: false
  • productname: Nextcloud
  • extendedSupport: false

nginx -version
nginx version: nginx/1.26.0

php --version
PHP 8.3.7 (cli) (built: May 13 2024 15:28:16) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.3.7, Copyright (c) Zend Technologies
with Zend OPcache v8.3.7, Copyright (c), by Zend Technologies

redis-server --version
Redis server v=7.0.15 sha=00000000:0 malloc=jemalloc-5.3.0 bits=64 build=8fef3e995a542118

Aus meinem Nextcloud Log:

{“reqId”:“wG8hGvpquqv19KdiY5xr”,“level”:3,“time”:“2024-05-29T17:12:05+02:00”,“remoteAddr”:“”,“user”:“”,“app”:“webdav”,“method”:“PROPFIND”,“url”:“/remote.php/dav/files//”,“message”:“RedisException: ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“userAgent”:“Mozilla/5.0 (Android) Nextcloud-android/3.29.0”,“version”:“29.0.1.1”,“exception”:{“Exception”:“Sabre\DAV\Exception\ServiceUnavailable”,“Message”:“RedisException: ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“Code”:0,“Trace”:[{“file”:“/var/www/html/nextcloud/3rdparty/sabre/event/lib/WildcardEmitterTrait.php”,“line”:89,“function”:“{closure}”,“args”:[“*** sensitive parameters replaced ***”]},{“file”:“/var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php”,“line”:456,“function”:“emit”,“class”:“Sabre\DAV\Server”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php”,“line”:253,“function”:“invokeMethod”,“class”:“Sabre\DAV\Server”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php”,“line”:321,“function”:“start”,“class”:“Sabre\DAV\Server”,“type”:“->”},{“file”:“/var/www/html/nextcloud/remote.php”,“line”:77,“function”:“exec”,“class”:“Sabre\DAV\Server”,“type”:“->”},{“file”:“/var/www/html/nextcloud/remote.php”,“line”:174,“function”:“handleException”}],“File”:“/var/www/html/nextcloud/remote.php”,“Line”:75,“message”:“RedisException: ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“exception”:{},“CustomMessage”:“RedisException: ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”}}

{“reqId”:“6MQn1mRWDn1qfraenOie”,“level”:3,“time”:“2024-05-29T17:12:39+02:00”,“remoteAddr”:“”,“user”:“”,“app”:“index”,“method”:“GET”,“url”:“/index.php/204”,“message”:“ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“userAgent”:“Mozilla/5.0 (Windows) mirall/3.13.0stable-Win64 (build 20240423) (Nextcloud, windows-10.0.22631 ClientArchitecture: x86_64 OsArchitecture: x86_64)”,“version”:“29.0.1.1”,“exception”:{“Exception”:“RedisException”,“Message”:“ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“Code”:0,“Trace”:[{“file”:“/var/www/html/nextcloud/lib/private/RedisFactory.php”,“line”:123,“function”:“auth”,“class”:“Redis”,“type”:“->”,“args”:[“*** sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/lib/private/RedisFactory.php",“line”:158,“function”:“create”,“class”:“OC\RedisFactory”,“type”:“->”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/lib/private/Memcache/Redis.php",“line”:73,“function”:“getInstance”,“class”:“OC\RedisFactory”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Memcache/Redis.php”,“line”:79,“function”:“getCache”,“class”:“OC\Memcache\Redis”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Memcache/WithLocalCache.php”,“line”:24,“function”:“get”,“class”:“OC\Memcache\Redis”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/User/Manager.php”,“line”:165,“function”:“get”,“class”:“OC\Memcache\WithLocalCache”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/User/Session.php”,“line”:239,“function”:“get”,“class”:“OC\User\Manager”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/L10N/Factory.php”,“line”:199,“function”:“getUser”,“class”:“OC\User\Session”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/L10N/Factory.php”,“line”:151,“function”:“findLanguage”,“class”:“OC\L10N\Factory”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/L10N/LazyL10N.php”,“line”:44,“function”:“OC\L10N\{closure}”,“class”:“OC\L10N\Factory”,“type”:“->”,“args”:[" sensitive parameters replaced ***”]},{“file”:“/var/www/html/nextcloud/lib/private/L10N/LazyL10N.php”,“line”:51,“function”:“getL”,“class”:“OC\L10N\LazyL10N”,“type”:“->”},{“file”:“/var/www/html/nextcloud/core/templates/update.user.php”,“line”:3,“function”:“t”,“class”:“OC\L10N\LazyL10N”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Template/Base.php”,“line”:180,“args”:[“/var/www/html/nextcloud/core/templates/update.user.php”],“function”:“include”},{“file”:“/var/www/html/nextcloud/lib/private/Template/Base.php”,“line”:150,“function”:“load”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/legacy/OC_Template.php”,“line”:142,“function”:“fetchPage”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Template/Base.php”,“line”:132,“function”:“fetchPage”,“class”:“OC_Template”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/base.php”,“line”:305,“function”:“printPage”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/base.php”,“line”:1008,“function”:“checkMaintenanceMode”,“class”:“OC”,“type”:“::”},{“file”:“/var/www/html/nextcloud/index.php”,“line”:49,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/var/www/html/nextcloud/lib/private/RedisFactory.php”,“Line”:123,“message”:“ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“exception”:{},“CustomMessage”:“ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”}}

meine config.php


<?php
$CONFIG = array (
  'instanceid' => '<ommited>',
  'passwordsalt' => '<ommited>',
  'secret' => '<ommited>',
  'remember_login_cookie_lifetime' => 1296000,
  'session_lifetime' => 1800,
  'session_keepalive' => false,
  'auto_logout' => true,
  'trusted_domains' =>
  array (
    0 => '<ommited>',
    1 => '<ommited>',
    2 => 'localhost',
    3 => '<ommited>',
    4 => '<ommited>',
  ),
  'datadirectory' => '/home/nextcloud/data',
  'dbtype' => 'mysql',
  'maintenance_window_start' => 1,
  'enable_previews' => true,
  'preview_max_x' => 1024,
  'preview_max_y' => 768,
  'version' => '29.0.1.1',
  'overwrite.cli.url' => '<ommited>',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '3306',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '<ommited>',
  'dbpassword' => '<ommited>',
  'installed' => true,
  'default_language' => 'de_DE',
  'default_locale' => 'de_DE',
  'default_phone_region' => 'DE',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 1,
  ),
  'app_install_overwrite' =>
  array (
    0 => 'occweb',
    1 => 'user_saml',
    2 => 'epubreader',
    3 => 'ransomware_protection',
    4 => 'geoblocker',
    5 => 'imageconverter',
  ),
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => '',
  'mail_smtphost' => '<ommited>',
  'mail_smtpport' => '25',
  'mail_smtptimeout' => 30,
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'no-reply',
  'mail_domain' => '<ommited>',
  'mail_send_plaintext_only' => false,
  'mail_smtpauth' => 1,
  'mail_smtpname' => '<ommited>',
  'mail_smtppassword' => '<ommited>',
  'mail_smtpstreamoptions' =>
  array (
    'ssl' =>
    array (
      'allow_self_signed' => true,
      'verify_peer' => false,
      'verify_peer_name' => false,
    ),
  ),
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' =>
  array (
    0 => 'admin',
  ),
  'twofactor_enforced_excluded_groups' =>
  array (
  ),
  'activity_expire_days' => 14,
  'allow_local_remote_servers' => true,
  'auth.bruteforce.protection.enabled' => true,
  'blacklisted_files' =>
  array (
    0 => '.htaccess',
    1 => 'Thumbs.db',
    2 => 'thumbs.db',
  ),
  'cron_log' => true,
  'defaultapp' => 'files,dashboard',
  'enabledPreviewProviders' =>
  array (
    0 => 'OC\\Preview\\PNG',
    1 => 'OC\\Preview\\JPEG',
    2 => 'OC\\Preview\\GIF',
    3 => 'OC\\Preview\\BMP',
    4 => 'OC\\Preview\\XBitmap',
    5 => 'OC\\Preview\\Movie',
    6 => 'OC\\Preview\\PDF',
    7 => 'OC\\Preview\\MP3',
    8 => 'OC\\Preview\\TXT',
    9 => 'OC\\Preview\\MarkDown',
    10 => 'OC\\Preview\\HEIC',
    11 => 'OC\\Preview\\Movie',
    12 => 'OC\\Preview\\MKV',
    13 => 'OC\\Preview\\MP4',
    14 => 'OC\\Preview\\AVI',
  ),
  'filesystem_check_changes' => 0,
  'filelocking.enabled' => 'true',
  'htaccess.RewriteBase' => '/',
  'integrity.check.disabled' => false,
  'knowledgebaseenabled' => false,
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'logtimezone' => 'Europe/Berlin',
  'log_rotate_size' => '104857600',
  'overwriteprotocol' => 'https',
  'preview_max_scale_factor' => 1,
  'profile.enabled' => false,
  'quota_include_external_storage' => false,
  'share_folder' => '/Freigaben',
  'skeletondirectory' => '',
  'trashbin_retention_obligation' => 'auto, 7',
  'updater.release.channel' => 'stable',
);

Ich benutze noch die Nextcloud 2FA APP, aber die 2FA Abfrage kommt nach dem Login nicht.

Laut google (danach geschaut: message":"ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?), redis Einstellungen geändert, mit requirepass und ohne. Nichts geändert. Selbst in der nextcloud mysql db die user Passwörter erneuert, leider auch nicht.

ich hoffe Ihr könnt mir weiter helfen. Danke im Voraus. Norman

Update: ich habe noch einige occ checks durchgeführt, und alles sieht eigentlich OK aus:

ncocc setupchecks
dav:
✓ DAV-Systemadressbuch: Keine ausstehende Synchronisierung des DAV-Systemadressbuchs.
network:
✓ WebDAV-Endpunkt: Ihr Webserver ist ordnungsgemäß eingerichtet um Dateisynchronisation über WebDAV zu ermöglichen.
✓ Datenverzeichnis geschützt
✓ Internetverbindung
✓ Unterstützung für JavaScript-Quellkarten
✓ JavaScript-Modulunterstützung
✓ OCS Anbieter-Auflösung
✓ .well-known URLs: Ihr Server ist korrekt für die Bereitstellung von .well-known-URLs konfiguriert.
✓ WOFF2-Datei laden
notifications:
✓ Push-Benachrichtigungen – Fair-Use-Richtlinie
security:
✓ Besitzer der App-Ordner: App-Ordner haben den richtigen Besitzer “www-data”
✓ Alte, von der Adminstration importierte Zertifikate
✓ Codeintegrität: Keine veränderten Dateien
:information_source: Für Header weitergeleitet: Ihre Remote-Adresse konnte nicht ermittelt werden.
✓ HTTPS-Zugriff und URLs: Sie greifen über eine sichere Verbindung auf Ihre Instanz zu, und Ihre Instanz erstellt sichere URLs.
✓ Alte serverseitige Verschlüsselung: Deaktiviert
✓ PHP-Version: Sie benutzen aktuell PHP 8.3.7.
✓ Zufallsgenerator: Sicher
✓ HTTP-Header: Ihr Server ist korrekt für das Senden von Sicherheitsheadern konfiguriert.
system:
:information_source: Brute-Force-Drosselung: Ihre Remote-Adresse konnte nicht ermittelt werden.
✓ Cron-Fehler: Der letzte Cron-Job wurde ohne Fehler ausgeführt.
✓ Cron zuletzt ausgeführt: Letzte Hintergrund-Jobausführung lief Vor 3 Minuten.
✓ Debug-Modus: Debug-Modus ist deaktiviert.
✓ Dateisperre
✓ Beginn des Wartungsfensters: Wartungsfenster zur Ausführung von umfangreichen Hintergrundaufgaben liegt zwischen 1:00 UTC und 7:00 UTC
✓ Memcache: Eingerichtet
✓ Architektur: 64-bit
✓ Temporärer Platz verfügbar: Das temporäre Verzeichnis ist korrekt konfiguriert:

  • 95.0 GiB verfügbar in /tmp/user/33 (PHP temporäres Verzeichnis)
    ✓ Push-Dienst: Kostenloser Push-Dienst
    database:
    ✓ In der Datenbank fehlen Spalten: None
    ✓ In der Datenbank fehlen Indizes: None
    ✓ In der Datenbank fehlen Primärschlüssel: None
    ✓ Datenbank mit ausstehenden Bigint-Migrationen: None
    ✓ MySQL Unicode-Unterstützung: MySQL wird als Datenbank verwendet und unterstützt 4-Byte-Zeichen
    ✓ Datenbankversion: 10.11.8-MariaDB-deb12-log
    ✓ Isolationsstufe der Datenbanktransaktion: Read committed
    config:
    ✓ Standard-Telefonregion: DE
    ✓ E-Mail-Test: Die Test-E-Mail wurde erfolgreich versandt
    ✓ CLI-URL überschreiben: Die Option “overwrite.cli.url” in Ihrer config.php ist auf “” festgelegt. Dies ist eine gültige URL. Die vorgeschlagene URL lautet “https://localhost”.
    ✓ Zugriffsrechte für die Konfigurationsdatei: Die Nextcloud-Konfigurationsdatei ist beschreibbar
    php:
    ✓ PHP-Standardzeichensatz: UTF-8
    ✓ PHP set_time_limit: Die Funktion ist verfügbar.
    ✓ Freetype: Unterstützt
    ✓ PHP getenv
    ✓ PHP-Speicherlimit: ?
    ✓ PHP-Module
    ✓ PHP OPcache: Korrekt konfiguriert
    ✓ PHP-Option “output_buffering”: Deaktiviert
    ✓ PHP Imagick-Modul

ncocc user:report
±-----------------±–+
| Account Report | |
±-----------------±–+
| Database | 3 |
| | |
| total users | 3 |
| | |
| user directories | 1 |
| active users | 3 |
| disabled users | 0 |
±-----------------±–+

auch habe ich mit: occ twofactorauth:disable <username> totp
für den User das 2FA ausgeschaltet. Hat leider auch nichts gebracht.

Fehlermeldung:

“app”:“remote”,“method”:“GET”,“url”:“/status.php”,“message”:“ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct?”,“userAgent”:“Mozilla/5.0 (Windows) mirall/3.13.0stable-Win64 (build 20240423) (Nextcloud, windows-10.0.22631 ClientArchitecture: x86_64 OsArchitecture: x86_64)”,“version”:“29.0.1.1”,“exception”:{“Exception”:

Die Meldung sieht in der Tat nach Redis Problem aus. Ich glaube nicht das wahlloses rumprobiere etwas birngt - die Einstellungen müssen zu dem installierten Redis passen und ggf müssen die beiden Applikationen nach anpassungen neu gestartet und die Logs weiter analysiert werden.

ich würde jedem dringend von Manipulationen an der DB abraten ausser man weiss sehr genau was man veranstaltet (in diesem Fall braucht man die Hilfe hier nicht)

aber ich würde evtl einen Schritt früer starten und die docs anschauen bzw das Forum Tag server_migration für das korrekte Vorgehen für die Migration konsultieren. und dann die Migration von vorne korrekt durchführen.

LÖSUNG: es lag an der mysql Datenbank. Ich habe nochmals via:

mysqldump -u<Benutzername> -p<Passwort> <Datenbank> > <SQL-Datei>

ein frische Kopie vom alten Nexcloud Server gezogen.

dann mit:

mysql -u<Benutzername> –p<Passwort> <Datenbank> < <SQL-Datei>

die Datenbank auf den Proxmox Nexcloud VM zurückgespielt. Dann zur Sicherheit den Nexcloud DB User neu angelegt, mit den Login Daten, wie diese in der Nexcloud config.php standen:

CREATE USER nextcloud@localhost identified by '<password>';
GRANT ALL PRIVILEGES on nextcloud.* to nextcloud@localhost;
FLUSH privileges;
quit;

danach:

systemctl restart php8.3-fpm
systemctl restart nginx

Und Bingo, login geht wieder… Also, gab es vorher ein Problem mit der eingespielten DB und dem Nextcloud DB User.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.