Use Skeleton-Directory without creating "Template"-Folder

Dear all,

I want to use a own skeleton folder. I changed the config setting “skeletondirectory” to my own separate path, assigned the necessary permission created in the skeleton folder an folder called “Upload” - Really simple structure :slight_smile: .

After this I created a new user to check the result. I login with the new user and I the the “Upload”-Folder :slight_smile: but I see any “Template” folder to. My goal is only to see the “Upload”-Folder without the “Template” folder.

Addionally after all these steps I added templatedirectory => " in the config (with the skeleton-directory) but this doesn’t work.

Is it possible that nextcloud uses only the “skeletondirectory” without creating a template-folder?

Best regards

Rainer

Could you include some screenshots.

Your grammar and spelling are confusing. Might want to proof read and edit your post so it is easier to understand what you are saying. Thanks!

Fwiw, I dealt with this issue by:

  • Disabling the template option from my config. Points to nothing, as you’ve shown.
  • Create a dummy user account called sharebot
  • Create everyone group, including all users.
  • Create folders as sharebot, which are shared & accessible to everyone.
    • can also be read-only in case you don’t want any users to modify certain parts.

Hey,

yes no problem.

Nextcloud Version: 23.0.3.2

Try 1:

  1. My skeleton folder looks like this:
    image

  2. My config.php looks like this:

  3. I created a new user “testuser” and do a login of this new user.
    image

Result: Folder in in skeleton directory was created successfully but it exists a folder called “Vorlagen” (in English “Template”). The folder “Vorlagen” should not be created.

Try 2:

  1. My skeleton folder looks like this:
    image

  2. My config.php looks like this:
    image

  3. I created a new user “testuser” and do a login of this new user.
    image

Result: No folder was created!

Hi,

is this a Bug?

Hi @Speed78,
You are missing the required support template. Please fill this form out and edit into your post.
This will give us the technical info and logs needed to help you on whether this is a bug. Thanks.