USB storage detection

Fresh install on Raspi 3B.
One USB hard drive attached (ext4 formated with volume label, 2TB)
At configuration NC continues to claim “ERROR: counted 2 devices. Please, only plug in the USB drive you want to format” while there is only on disk attached. If disconnecting the disk it claims (correctly) that zero disk are attached. Tried many times with same result.
During initial testing of NC I used a USB memory stick and it worked flawless in first attempt.
Any hints to what I’m doing wrong?

you can check with lsblk -f

Thank you for commenting.
The attached hard drive (label=memorydisk) is listed as follows:
pi@nextcloudpi:~ $ lsblk -f
`-sda1 ext4 memorydisk 120c0ba1-31af-4940-8ff5-69953b5ac7e2 1.7T 0% /media/memorydisk

I wonder if this is a clue. “USBdrive” appears when i connect the USB hard drive.
pi@nextcloudpi:~ $ ls /media
USBdrive memorydisk

I think the reason was that the USB drive was already recognized by NC, so I only had to change the storage location. The problem is solved.
But wow, synchronizing is slow. 1.5GB/3400 files will run for approximately 20 hours. I will investigate if there is some mistakes in my configuration.