Usage Terms of Service App

Hello everybody,

I searched through the forum but could not find a solution for my problem, to be honest I am not sure if there is actually a problem or maybe I am just to stupid to use the app.

I installed the App and went to settings-menu choosing “terms of Service” then. Here I choose a language, region and put some text in it and save.

And then??

The description of the App says there should be somekind of popup to the users when they login and that they have to check a confirmation.

But nothing happens…

So my question is, can someone please be so kind and explain me what to do?

Happy new year to you all!

Please excuse my push of this topic but I was not able to find a solution to my question yet.

If anyone in this forum can help me with that I would be reeeally thankful!

same problem any solution? please help us

Me too, any idea?

Hey, I also had this problem but if I set my terms to “global” instead of in my case “United States of America (US)” it started working. Now it shows up for my users. Hope this helps!

For me today sometimes (for registered users) it worked, mostly not.
Settings: global

For shared links it should work too? But than it needs this “occ command” right?

occ command (ownCloud console)
./occ config:app:set terms_of_service tos_on_public_shares --value ‘1’

registered users it says, is enabled by default:
./occ config:app:set terms_of_service tos_for_users --value ‘0’