Uploads fail on files over 2MB despite updating php.ini

PHP Version 7.4.11
NextCloud V20 (Latest as of last night)

running php -i | grep "Loaded Configuration File returns /etc/php/7.4/cli/php.ini
editing that files upload_max_filesize to 999G and post_max_filesize to 0, reboot the server, uploading a file over 2MB no longer returns the error about upload_max_filesize, but checking the “system” tab of the admin settings still lists the php max upload size as 2MB, what am I missing? Is there a second file somewhere I need to modify as well?

Most likely you running into the usual php trap and mixing-up the php cli and the web component. The used php command (php -i) can only be used to check cli specific parameters. If you upload files, the php web component is used and therefore you should make sure that your configuration changes are also correctly set for it. This can easily been done by creating a php file, which contains “<?php phpinfo() ?>”, and open it on your server using your web browser.

You can also see the php version, memory, and file upload limits that nextloud sees by going to ‘settings’, then ‘system’ (at the bottom of the left-hand menu), then scrolling to the bottom of the page.

My server contains a block showing:

Version: 7.4.11
Memory Limit: 512 MB
Max Execution Time: 3600
Upload max size: 512 MB