Uploaded files not visible in web interface

I’m using the latest version of the official VM. I’ll add all the other details if needed, but I’ll just ask first in case it’s a known problem.

Generally things seem to be fine, and several folders have been created without problem. But I have one folder in which only the first 6 files are shown in the web interface. Several other files have been uploaded, but do not appear. They are visible by looking directly in the user files on the server, and, if I try to add them again through the web interface, I’m told they already exist, and prompted to overwrite them.

All files have been added normally through the web interface. The files are a mixture of PDFs and .maff archives.


And here’s a strange thing - if I click the ‘select all’ checkbox at the top of the files list in the folder, it shows the correct number of files. Then, if I drag them, the transparent selection that shows the grabbed files shows all the files correctly.

Might be onto a bug, here.

I’ve tracked it down to a file that had quotation marks in its filename. As soon as that file is added to a folder, the folder display goes crazy, hiding files and showing a file count of negative three in a folder with sixteen files.

I tried adding quotation marks to another filename and uploading it to an existing folder, which had a similar effect.


Might be related to this issue, which has been closed as fixed in the latest version. Does anyone know if it fixes the problem of quotation marks in filenames, as only folder names were discussed in the bug report?

You can try this fix yourself (don’t forget to backup your data before):

or wait until NC 11.0.2 is released (should be soon, the release candidates are already out: Help testing the next release candidates).

That’s fine, I’ll wait for the main update. It’s only an edge case for me, that’s easily avoided now I know what’s going on.

Thanks for the reply.

I ran into this a while back also. Won’t be long before it drops :slight_smile: