Upload to shared folder broken in Nextcloud 10?

Situation: standalone server, no federation, no external storage.
User admin has configured a InstantUpload folder and shared it with user1.
User1 could (instant)upload to this folder without any problems.
After upgrade to N10, user1 no longer can upload to InstantUpload. Obviously, I have not changed the config or premissions in any other way.
Upload failure in both web, Android client and WebDAV.

Log complains about “Insufficient storage” - which is not the case, as user admin can still upload to the same folder. It also points to quota. Those were also not constraining, but I tried to change them anyway (running into the issue posted elsewhere in this forum that I cannot set Default or Unlimited quota).

I also tried ‘quota_include_external_storage’ => false. That did change the storage count and solved another user’s problem (she had a 5GB quota, but admin shared >20GB with her, and she was barred from uploading in N10 because ‘quota exceeded’), but not this one.

As this suddenly stopped working after upgrading from 9.0.53 to 10.0, I’m pretty confident this is a bug or at least unintended behaviour – right?


Yes if an upgrade directly breaks a function, then there is something wrong. Open a new bug report on github and fill out the template.

1 Like