Upload speed to server - wifi

Hello,

I Have a problem, this is strange situation. I want to upload the file. But always upload at 2-5 mb/s. No matter if encrytion is enabled. This is clean instalation witch docker without https and encryption. This is nextcloudpi. Screen below:

Before digging any further into the nextcloud installation, use a ethernet connection via cable to test upload speeds. Just to sort out any kind of wifi issue.

I think it is a general problem with WebDAV. Please test the speed with sftp (server: sftp-subsystem of sshd, client: WinSCP or Filezila). Post values.

Here you are. This is strange. No matter how i upload, clean instalation, WebDav, via www. Always the same. I’m perfectly sure that my gear is ok. The transfer might be around 20-30 mb/s.

MB/s is not Mb/s. The factor is 8
Megabyte per second vs. Megabit per second.
Perhaps here is your problem (nextcloud and sftp).

Hmmm, good point. But the transfer is low. I see, that is problemmeny of users. Someone try to delete http2 from nginx, but I only use on port 80 to test transfer.

Yes. I have sometimes similar problems without a solution. If i upload with the android app there are sometimes seconds between the upload from different files. Upload with sftp is much faster. What a pity.

I try to another test. Try upload via samba. The same result.

Could be that you hit Server CPU Limits? What is your Server CPU usage during the Upload.
I would say ftp is more friendly to CPU as WebDAV and Samba somewhere in-between.

It is also depends how you access you NC direct via IP, or Domain name - LAN like hostname.mynetwork or internet domain.com? In last case your packages could be routed via your NAT and will hit your internet provider Limits.

Is your server also connected via Wifi, or Ethernet?

Check you negotiated Wifi Speed in windows 10 --> Settings --> Networks --> Change adapter Settings --> Wifi --> Status.
grafik